Jump to content
Sign in to follow this  
mooms

.NET 4.0 et 4.6.x: ajouter le langpack Fr aux installateurs de ricktendo

Recommended Posts

MAJ pour .NET 4.6

Testé l'installeur créé sous Windows 7 x64 & x86 Fr avec .NET 4.5.2 installé, fonctionne parfaitement.

Share this post


Link to post
Share on other sites

Rien de visible pour les utilisateur des runtimes, ça concerne les développeurs, (ça coïncide avec la sortie de Visual Studio 2015 et de Windows 10), et il faudra donc tôt ou tard l'installer pour profiter des applis développées pour. ça remplace évidemment la 4.5.2.

Un coup de google te donnera plus d'infos.

Share this post


Link to post
Share on other sites

It's v4, not v4.7, you were mislead because of the .7z extension.

Yes it's still valid, just tested with W7 X64 French and 2015-10-30 version.

Share this post


Link to post
Share on other sites

bonjour Monsieur
j'ai bien suivi votre tutoriel nett framworks creer dans un dossier mais apres ou je met ses fichiers microsoft.net si pour pouviez me renseigner je vous en serait reconnaissant d'avance merci

 

 

Hello sir
I followed your tutorial nett framworks create a folder but after I put his or microsoft.net for files if you could inform me I would be grateful thank you in advance

Share this post


Link to post
Share on other sites

Hello,

Je ne sais pas, ça dépend de ce que tu veux faire avec !

 

Le fichier dotNetFx46_Fr.exe obtenu est un installateur silencieux, tu peux l’intégrer à une installation de Windows via WinToolkit par exemple.

Si tu veux simplement installer .Net 4.6 sur un PC il suffit de le lancer (double-clic), tu peux ensuite supprimer l'installateur.

Share this post


Link to post
Share on other sites

MAJ pour .NET 4.6.1:

 

- Suppression de la partie pour .Net 4.0, elle reste dispo dans les anciennes versions.

- Passage de l'archive au format rar et renommage (sans accent).

- Création d'une variable dans le script permettant de traiter un autre language pack que le français plus facilement.

 

 

Notes:

J'ai tenté d'incorporer la dernière version de 7za.exe (la v15.14) mais le sfx créé était 2x plus gros (!), donc on reste sur la v9.22 qui a fait ses preuves.

Le problème semble le même avec le version graphique de 7zip 15.14, soit la syntaxe a changée, soit il y a un gros problème avec cette version....

La nouvelle version de IPB (le software qui fait tourner le forum) est vraiment mal foutue, j'ai galéré pour MAJ le 1er post, (clic involontaire sur les liens à éditer qui font tout perdre...) j'espère que NIM va restaurer la possibilité d'éditer les posts au format brut...

 

Décidément les nouvelle versions sont bien foireuses ces temps-ci !

Share this post


Link to post
Share on other sites

Bonjour,

@mooms,

ayant certaines vérifications à faire sur mon SFX DNF461, j'en ai profité pour regarder ton utilitaire.
Rien de particulier à signaler si ce n'est que personnellement j'ajoute une version plus légère pour les petites configurations x86.

Concernant 7-Zip, je n'ai pas encre eu le temps de tester la 15.14. J'utilise encore la version 15.12 et j'ai constaté des taux de compression légèrement amélioré.
Effectivement, le paramétrage a changé. D'une part, le mode par défaut est LZMA2 (il faut donc changé le module SFX) et d'autre part la Taille du dictionnaire est primordiale.
Tu utilises le paramètre -mx9 donc par défaut la taille est 64 MB soit -md=26 ou -md=64M (2 puissance 26 donne 64MB).
En augmentant ce paramètre, le gain est important. Avec un i5-4690 et 8 Go de mémoire, j'utilise jusqu'à -md=29 soit 512 MB. Le gain n'est appréciable que pour des fichiers importants. J'ai testé la décompression sur un ancien  portable Acer en x86 avec 2 Go et c'est bon.

@+

 

Share this post


Link to post
Share on other sites

Hello icare,

 

J'ai pensé aussi à proposer une version uniquement x86, mais je ne suis pas sûr de savoir quels fichiers/dossiers je devrais supprimer (autres que ceux en "*64" évidemment).

 

Pour ce qui est de la compression, je viens de comparer la compression LZMA2 avec un dico de 512M sur la 15.14 (version gui) avec celle en LZMA en 512M et en 64M de la 9.22 que j'utilise dans le script:

Entre 64 et 512, le gain est faible, environ 1Mo, et entre LZMA et LZMA2 le gain est quasi nul:

160116102031303949.png

Par contre l'utilisation mémoire est multipliée par 6 (!): on passe de 700 Mo à plus de 4 Go. Le seul avantage que j'ai pu voir c'est que LZMA2 sait utiliser 4 threads là ou LZMA n'en utilise que 2.

 

Si tu veux essayer la version console réduite (7za.exe) en version 15.14, voici le lien: 7z1514-extra.7z

Share this post


Link to post
Share on other sites

Bonjour,

@mooms,

pour les versions x86, c'est automatique avec une installation administrative :

msiexec /a netfx_Full_x86.msi TARGETDIR="%CD%\x86"
msiexec /a netfx_FullLP_x86.msi TARGETDIR="%CD%\x86"

Les guillemets sont utiles pour ceux qui utilisent des noms de dossier avec espace.

Pour les problèmes de compression, tes valeurs correspondent aux miennes.
Le LZMA2 n'apporte rien pour ce genre de fichier. Le gain est intéressants pour des fichiers déjà compressés par exemple en cab ou pour des SFX.
Je pense avoir un peu de temps cette semaine pour m'intéresser aux autres paramètres.
Pour mes SFX, l'occupation mémoire n'est pas un critère très important car je mets en ligne un produit fini. l'utilisateur final n'est pas concerné.
La seule restriction est qu'avec d=512M, la décompression s'appropriera un peu plus de 512 Mo. Je pense que ce n'est plus un problème actuellement.

Sinon, je ne pense pas qu'il y ait de différences importantes entre 15.12 et 15.14.
De plus sur mon PC de travail, j'utilise 7z.exe (au lieu de 7za.exe) que je place dans %WINDIR%.
J'ai ainsi accès à la ligne commande depuis tout mes dossiers sans avoir à ajouter quoique ce soit. Curieusement 7z.exe sait retrouver 7z.dll (qui lui est nécessaire) dans n'importe quel dossier.
Évidemment, j'ai toujours 7za.exe sur une clé.

@+

 

Share this post


Link to post
Share on other sites
On 3/4/2016 at 0:55 PM, mooms said:

ricktendo a officiellement pris sa retraite:

 

Une grande perte dans le monde de l'unattended. Quelqu'un va reprendre ses créations ?

Share this post


Link to post
Share on other sites

Petite màj du script pour fonctionner avec les versions 4.6.x:

Le fichier cmd est configuré pour travailler avec la langue française (fr) et la version 4.6.2, mais il suffit de modifier le fichier cmd et de changer les variables en début de fichier pour changer la langue et/ou la version (remplacer vrs=462 par vrs=463 pour une éventuelle future version 4.6.3, lng=de à la place de lng=fr pour créer une version avec le language pack allemand, etc...)

Les packs sont toujours maintenus par ricktendo ici:

http://repacks.net/forum/viewtopic.php?f=6&t=7

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...