Jump to content
Thiersee

[Not solved but closed] Error code 999

Recommended Posts

Hi,

 

I got a problem with a batch file and two programs returning error code 999 in the log-file.

 

What does this code mean?

 

If I start the programs and the batch-file manually they works.

 

Regards, Thiersee

Edited by Thiersee

Share this post


Link to post
Share on other sites

Ok, here ist it!

Together with config.js I packed the WPI-log.txt and my WinToolkit.INI, so you can see what is integrated in the ISO.

 

BTW, the two programs not running within WPI run in windows and if I put them in Wintoolkit as silent-installer.

 

Two time tried, two time the same error; every time absolutely the same ISO and the same WPI-Package.

config.7z

Share this post


Link to post
Share on other sites

There is the same error with Skype.

 

Again:

after the WPI-run, where those two program give an error 999, I start them manually (outside of WPI) and they will be installed without error!

 

Share this post


Link to post
Share on other sites

With SFX-Maker.

 

Skype: Skype_XYZ.msi /passive /norestart

Copyfile: as folder and CopyFile.bat as executable; the folder mentioned in the .bat are obviously present.

 

CopyFile.bat:

@echo off &setlocal


if defined ProgramW6432 (
  set "pf=%ProgramW6432%"
  set "cs=ClassicShell"
) else (
  set "pf=%ProgramFiles%"
  set "cs=ClassicShell"
)
if defined ProgramFiles(x86) (set "pf_x86=%ProgramFiles(x86)%") else set "pf_x86=%ProgramFiles%"

:: Hier dein Code, in dem du mit folgenden Variablen arbeitest.
:: ECHOs und PAUSE entfernen, wenn du siehst, dass die Pfade korrekt sind.

copy "%cs%\*.dll" "%pf%\ClassicShell\"

 

Regards, Thiersee
copy "ImgBurn\*.lng" "%pf_x86%\ImgBurn\languages\"
copy "MozBackup\*.lng" "%pf_x86%\MozBackup\"
copy "IrfanViewLanguage\*.*" "%pf_x86%\IrfanView\Languages\"

 

This batch, built in the same way, works fine without issues.

@echo off &setlocal


if defined ProgramW6432 (
  set "pf=%ProgramW6432%"
  set "cs=ClassicShell"
) else (
  set "pf=%ProgramFiles%"
  set "cs=ClassicShell"
)
if defined ProgramFiles(x86) (set "pf_x86=%ProgramFiles(x86)%") else set "pf_x86=%ProgramFiles%"
copy "AIDA64-Reg\pkey.txt" "%pf_x86%\FinalWire\AIDA64 Extreme Edition"

Share this post


Link to post
Share on other sites

About Skype msi!

 

The next WPI release v8.6.7 will have a new function {MSI}:

 

http://www.msfn.org/board/topic/158273-wpi-86-and-beyond-bugbugfix-thread/page__view__findpost__p__1042077

 

 


**** Added {CMD} to the list of functions.
**** Add Win2k to the conditions.
**** Fixed a executebefore64bit error.
**** User file written version updated slightly.
**** Fixed a autologoncount error.
**** Fixed a alert sound location error.
**** More info added to the installer log.
**** Removed more old leftover code.
**** Added setfilesystem to the conditions.
**** More fontinstaller improvements.
**** Tons of textual errors fixed.
**** Added {MSI} to the commands for standard msi files.
**** Added alerts to themewizard when exiting.
**** Fixed a couple of resolution errors.
**** Restored "Float" for the tooltips.
**** Tons of minor features improved.
**** Fixed AutoAdminLogin feature.
**** Added HiPerformance Power Scheme for Win7.

 

 

 

Tested and working fine:

http://www.msfn.org/board/topic/158272-languages-themes-manuals-mods/page__view__findpost__p__1040896

 

However it's only a "Supporter release"...

But many bugs have been solved and I encourage you to acquire the new WPI_v.8.6.7

 

Cheers and regards

Edited by myselfidem

Share this post


Link to post
Share on other sites

Hi,

 

don't ask me how, why and so on: after the windows-update of yesterday and with the same WPI, integrates Skype without issue, my batch-file does not :censored: !

Anyway, the image is now to big for a normal DVD-R, therefore is WPI at the moment not for me.

 

Thanks again for your efforts.

 

Thiersee

Share this post


Link to post
Share on other sites

I think because he no longer has the problem, so [closed], but he has no idea why it works now when it didn't earlier [Not solved but].

 

Cheers and Regards

Share this post


Link to post
Share on other sites

I think because he no longer has the problem, so [closed], but he has no idea why it works now when it didn't earlier [Not solved but].

 

Cheers and Regards

Exactly :thumbsup_anim: !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...