• Announcements

    • NIM

      Site Donations   02/04/2016

      Dear members, due to a problems with Donations Sidebar module, we are unable to use this plugin for accepting new donations.
      If you would like to donate some funds for our site costs you can do so by using our Paypal address (donations[at]wincert.net) directly from the Paypal web site. Thanks!
bjfrog

[How To] Integrate Vista SP2 into Vista SP1 DVD?

56 posts in this topic

i have a feeling that when i buy a version of windows vista SP2 will come out. <_<

Share this post


Link to post
Share on other sites

To bjfrog:

Many thanks for the useful informations however I'm facing a problem, the command "compcln.exe" does not work in OOBE after installing SP2 and reboot, if you do "yes" the windows in prompt just close and nothing else.

Another question when "generalize" and "shutdown" in OOBE the system restart, is this normal or not ??

Could you please give more information or am I making a mistake ??

Thanks for your reply.

Share this post


Link to post
Share on other sites
To bjfrog:

Many thanks for the useful informations however I'm facing a problem, the command "compcln.exe" does not work in OOBE after installing SP2 and reboot, if you do "yes" the windows in prompt just close and nothing else.

Another question when "generalize" and "shutdown" in OOBE the system restart, is this normal or not ??

Could you please give more information or am I making a mistake ??

Thanks for your reply.

It seems that nobody here is interested by the question.

However the problem is solved.

Thanks anyway. :confused02:

Share this post


Link to post
Share on other sites
It seems that nobody here is interested by the question.

However the problem is solved.

Thanks anyway. :confused02:

I wouldn't say that. Probably those who have read this topic didn't know how to help you.

Share this post


Link to post
Share on other sites
I wouldn't say that. Probably those who have read this topic didn't know how to help you.

Sorry you are right, I apologize :sweatingbullets:

Share this post


Link to post
Share on other sites
To bjfrog:

Many thanks for the useful informations however I'm facing a problem, the command "compcln.exe" does not work in OOBE after installing SP2 and reboot, if you do "yes" the windows in prompt just close and nothing else.

Another question when "generalize" and "shutdown" in OOBE the system restart, is this normal or not ??

Could you please give more information or am I making a mistake ??

Thanks for your reply.

HI Welcome to wincert!

Sorry for the late and thanks for the feedback

the issues that you mentioned should not happen if you follow the steps i posted,so far no problems like you said happen to me, i have created a couple of images for me and my friends,but now i have no chance to help u, congradulation!

feel free just let me share your success and know what cause those problems,

BTW i should give a update to the partition section

Using Vista partition manager will cause "hareware change" prompt when first boot during installation if you use a vlited image( Problem will be fixed automatically if you contiune to install), this wont happen using the fully image,iam not sure what cause that,but a solution will fix that.

Using diskpart command included in th PE ISO instead of Vista partition manager

so save below codes as a text file, ie first.txt Add first.txt into PE.ISO rootdir

boot machine using PE.ISO ,run this line diskpart /s first.txt under pe environment

select disk 0
clean
create part pri size=5000
create part pri
select part 1
active
Format fs=ntfs label="Image"quick
select part 2
Format fs=ntfs label="Vista"quick
exit

Share this post


Link to post
Share on other sites

Hi,

In fact the problem was coming first from OOBE (System preparation tool 3.14) when I selected OOBE with select "generalize" and shut down options "shutdown" the virtual machine restarted, This problem has already been reported from OEM manufacturer, if I remember..

And I could not clean the system before with "compcln.exe" because you have to answer Y or N when this program is launched. My installation was done with a french vista and SP2 in English and then the answer should be O or N for "Oui" or "Non" in french.

I finally have taken an vista in English (first generation without SP1 integrated) and I installed SP1 in OOBE and then SP2. I could clean, shutdown the machine without problem and capture the wim file.

I tested the new fresh DVD in VMWare without any problem.

However I have a question : Is it possible to download all the update for vista in OOBE mode, I mean automaticly from Microsoft, there is a tool for OEM I think to force updates ??

Thanks and have a nice day. :thumbsup_anim:

Share this post


Link to post
Share on other sites

Why not try to capture a image from an installation that all updates have been installed already,its still work i think

ill try on OOBE mode when i get some time,thanks

Share this post


Link to post
Share on other sites

I did the "reverse integrate" procedure and I managed to integrate in a clean source the SP1+SP2+IE8 in HomePremium edition. I created the ISO and tested and works perfect. But I have a small question. When I install the OS I have no longer the option to select any other edition than HomePremium. eg I cannot select the Ultimate edition even I know it is without SP2.

Share this post


Link to post
Share on other sites

I am not POSITIVE but I think this is for one version only, OR you have todo each version one at a time.

Share this post


Link to post
Share on other sites
I am not POSITIVE but I think this is for one version only, OR you have todo each version one at a time.

After searching in these links:

OK, so it's a 'reverse integration' method. Just like when SP1 was released.

Like here:

http://www.winbeta.org/comments.php?catid=1&id=9536

And here:

http://www.mydigitallife.info/2007/09/05/s...se-integration/

I found this:

It has to be noted that the above method is for a single edition of Vista. If one wanted to integrate SP1 into all the editions of Vista, they would have to follow Steps 1-5 for each edition and use the imagex /append function to build an install.wim that contains all the editions of Vista.

Did I had to use the "/append" switch at the first integration ???

Share this post


Link to post
Share on other sites

Nice info, just missed this post till today lol thanks 4 the bump

Share this post


Link to post
Share on other sites

what i suggest is intergreting beta SP in dvd and installing it is a bad idea it will lead only problem...

Share this post


Link to post
Share on other sites
i post the process,hope it helpfull to those wanna creating a Vista SP2 DVD.

MUST thanks my friend Qiuping Huang provide this method,

and now I use VMWare to make it work

First of all let's do some preparations

1.Download Windows Vista serice pack 2 pre-beta from here,

Vista Serice Pack 2 pre-beta x86

then create it to be an ISO file,I named it SP2BETA_16497.iso

2.Install VMWare workstation ,create a virtual machine with a 20GB virtual hard disk and allocate all disk space to the virtual harddisk,this will be helpfull to enhance virtual machine performance,Rick has made a good lite edtion,VMWare Workstation Lite,just regiter a trial key from vmware.

3.Create a PE2.0 ISO file must include imagex utility,you need not do this if you already have one

How to create a PE2.0 ISO?

1st dowload MS windows AutoInstallkit(AIK) for Vista sp1 from here

Windows Autoinstall Kit(WAIK)

Install WAIK via mount WAIK ISO file to virtual CD

click "Windows PE Tools Command Prompt" shortcut when installation finished

Run below command line at command prompt window,

copype.cmd x86 d:\PE

copypexf2.gif

then copy all the folders/files under "C:\Program Files\Windows AIK\Tools\x86" into "d:\pe\ISO" folder

copytoolmx0.gif

Run below line under "C:\Program Files\Windows AIK\Tools\x86" to make a PE2.0 ISO( 218MB),i named it PE.ISO

oscdimg.exe -bd:\PE\etfsboot.com -h -u2 -m -lWINPE d:\PE\ISO d:\PE.iso

creatpejo1.gif

about oscdimg usage: oscdimg -help <categories>

Yes, I've gotten this far but I don't see how you go from the "d:\PE>" to "c:\" to run the command "C:\Program Files\Windows AIK\Tools\x86>oscdimg.exe -bd:\PE\etfsboot.com -h -u2 -m -lWINPE d:\PE\ISO d:\PE.iso" on the Windows PE Tool Command Prompt?

Forgive me for being so new with this but I am very interested in making a Vista SP1&2 bootable disk.

I hope that there is someone to respond to this inquiry. Thank you.

John

PS Plus I've realized that I also need to reverse integrate SP1 first. So, I imagine that any advice here will help me with both.

Share this post


Link to post
Share on other sites
i post the process,hope it helpfull to those wanna creating a Vista SP2 DVD.

MUST thanks my friend Qiuping Huang provide this method,

and now I use VMWare to make it work

First of all let's do some preparations

1.Download Windows Vista serice pack 2 pre-beta from here,

Vista Serice Pack 2 pre-beta x86

then create it to be an ISO file,I named it SP2BETA_16497.iso

2.Install VMWare workstation ,create a virtual machine with a 20GB virtual hard disk and allocate all disk space to the virtual harddisk,this will be helpfull to enhance virtual machine performance,Rick has made a good lite edtion,VMWare Workstation Lite,just regiter a trial key from vmware.

3.Create a PE2.0 ISO file must include imagex utility,you need not do this if you already have one

How to create a PE2.0 ISO?

1st dowload MS windows AutoInstallkit(AIK) for Vista sp1 from here

Windows Autoinstall Kit(WAIK)

Install WAIK via mount WAIK ISO file to virtual CD

click "Windows PE Tools Command Prompt" shortcut when installation finished

Run below command line at command prompt window,

copype.cmd x86 d:\PE

copypexf2.gif

then copy all the folders/files under "C:\Program Files\Windows AIK\Tools\x86" into "d:\pe\ISO" folder

copytoolmx0.gif

Run below line under "C:\Program Files\Windows AIK\Tools\x86" to make a PE2.0 ISO( 218MB),i named it PE.ISO

oscdimg.exe -bd:\PE\etfsboot.com -h -u2 -m -lWINPE d:\PE\ISO d:\PE.iso

creatpejo1.gif

about oscdimg usage: oscdimg -help <categories>

:sweatingbullets: OK, again please forgive me, this is my first time using a virtual machine environment and I'm just getting familiar with it.

My question is about where you are installing the WAIK program?

You say: "Install WAIK via mount WAIK ISO file to virtual CD".

I take it that you mean to install it in the virtual machine, but how can you do this before there is an Operating System installed first?

DON'T YOU HAVE TO INSTALL AN OS FIRST ON THE VIRTUAL MACHINE? before you can install the WAIK?

Thank you,

John

Edited by Johnz414

Share this post


Link to post
Share on other sites

Hi,

I'm new here, I tried following the SP2 integration guide here to integrate the final SP2 but I get a fatal error when I press OK on the sysprep window, it seems to be the problem described here:

http://support.microsoft.com/kb/929828/en-us

but I am not using any unattend file and a windows vista ultimate x86.

any ideas?

---EDIT---

OK, I decided to skip the step that was failing, vlite reported the new file as SP2 file so it seems to be ok, I'm now integrating some additional things with vlite (Language pack, drivers & IE8) and will test on VMware, I'm hoping it will work well because I really need this updated disc in order to reainstall my computer, I currently have major errors in my system.

---EDIT 2---

Not working, get errors during setup, will try again from the beginning

---EDIT 3---

Nope, still getting same error on sysprep, can't figure out why and can't seem to bypass it, any help would be appreciated

---EDIT 4---

OK, I give up, I tried everything I could think of and every solution I read about and nothing works, I'll just reinstall with my Vista SP1 DVD and install SP2 manually, once my computer is working properly I can find the time to get the SP2 integration to work, still, if anyone got any ideas, please let me know.

Edited by vollachr

Share this post


Link to post
Share on other sites

vlite can be used to integrate sp. it is easy.

Share this post


Link to post
Share on other sites

Try Windows 7 Toolkit (W7T) to integrate Vista Sp2. Before integration extract the ".cab" file from the ".exe" with this command :

Windows6.0-KB948465-X86.exe /X:C:\Sp2extract

Finally integrate this file "windows6.0-kb948465-X86.cab" with W7T available here :

http://www.wincert.net/forum/index.php?showtopic=6017

Doesn't Work Sorry :(

Edited by wallace1

Share this post


Link to post
Share on other sites
Try Windows 7 Toolkit (W7T) to integrate Vista Sp2. Before integration extract the ".cab" file from the ".exe" with this command :

Windows6.0-KB948465-X86.exe /X:C:\Sp2extract

Finally integrate this file "windows6.0-kb948465-X86.cab" with W7T available here :

http://www.wincert.net/forum/index.php?showtopic=6017

It works for me. :thumbsup_anim:

you have proof of this? :) funny you see no mention of this on the internet as everybody wants to be able to integrate SP2 without jumping through hoops to do it.

Share this post


Link to post
Share on other sites

Already tested and installed on virtual machine and physical machine,it work fine.

Image file generated use this method still support Vlite ,VUT,GimageX to view and edit,good luck.

It's great post/tutorial! Thank you veru much! But I don't know what to do with the "INSTALL.WIM" file... Which is the next step?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now