Jump to content

mooms

Global Mods
  • Posts

    2,339
  • Joined

  • Last visited

  • Days Won

    142

Posts posted by mooms

  1. Et sur Linux tu est root constamment ou tu as une invite de mot de passe ?

    Le problème de désactiver UAC c'est que certains programmes se mettent à se comporter bizarrement, donc même si tu utilises peu Windows il vaut mieux le réactiver, quitte à le laisser au niveau mini.

    Ne t'inquiète pas pour la "pollution", ça permet d'aborder le sujet, et vu que le forum est un peu moribond c'est plutôt une bonne chose.

  2. On peut toujours si on ne bidouille pas son Windows:

    41221a2718a73c3276d1bc0c3364aec8573511f3

     

    C'est simplement parce que tu lances Explorer en tant qu’administrateur que tu as ce comportement, et Firefox refuse de se lancer en tant qu' administrateur désormais, c'est une très bonne chose pour un logiciel qui est en ligne de front sur Internet: il se connecte à des milliers de machines distantes, plus ou moins dignes de confiance, et ne pas avoir les droits administrateur inutilement est une sécurité importante.

    Ton lien explique d'ailleurs bien que c’est une mesure de sécurité de ne pas laisser Firefox avec les droits admin.

    Je suppose que tu désactives l'UAC. En faisant cela tu rends Windows bien plus sensible aux attaques, puisque n'importe quel exécutable a les droits administrateur, comme au temps de Windows XP.

    Ne compte pas sur moi pour ajouter ce tweak, je désapprouve la désactivation de l'UAC.

    Fais-moi plaisir et réactive l'UAC, tu verras, cliquer sur OK de temps en temps n'est pas si compliqué, et au moins tu sauras quand un logiciel demandera à effectuer une action privilégiée, c'est aussi éducatif.

     

     

  3. Ce n'est pas une coquille, tu peux encapsuler la ligne complète dans des quotes.

     

    Merci du compliment, sache que je suis 100% autodidacte là-dedans, j'ai juste cherché sur le net des exemples de codes et appris comme ça au fur et à mesure. Il y a certainement des trucs qui feraient bondir un développeur.

    Par contre je te conseille de passer à Powershell si tu ne codes pas pour XP, beaucoup de choses sont plus simples qu'en batch.

  4. On 10/6/2019 at 8:24 PM, rhahgleuhargh said:

    mooms Thiersee

    Bienvenue sur Windows 10 !

    Je ne sais pas si 10 est plus réactif que 7, mais sur ma vieille config de 2013 (I5 Sandy Bridge, vieux SSD Intel 2ème génération, 8 GO DDR3) il démarre et lance les programmes toujours au quart de tour. J'espère juste que M$ fera plus attention à soigner ses mises à jour majeures, car on a eu notre lot de bourdes avec 1809 et 1903...

    7 rame de plus en plus sur mes machines virtuelles, et me fait de plus en plus penser à XP avec ses innombrables patches plus ou moins buggés. Très bon OS, mais il a fait son temps et a pris un méchant coup de vieux. De 7, je regrette quand même son orientation multimédia et sa gestion des partages réseaux qui n'est pas vraiment top avec 10, surtout avec d'autres OS...

     

     

    Oui, 7 me semble de plus en plus lent et buggé, ce qui n'était pas le cas avant...j'ai constaté de visu des bugs introduits par certaines KB et jamais corrigés.

    Je soupçonne MS de l'avoir fait sciemment, histoire de pousser les nombreux réfractaires à 10 à revoir leur position...

    Après comme tu le dis 7 a fait son temps, 10 ans l'année prochaine tout de même, et 10 me semble relativement mature...reste à espérer en effet que les mise à jour majeures ne nous foirent pas tout ça, c'est inconvénient d'avoir un OS en perpétuelle évolution.

  5. J'avais d'ailleurs oublié de mettre des ^ à certains endroits ce qui faisait que les lignes reg delete n'étaient pas ajoutées au fichier de config.

    J'ai aussi ajouté un waitall devant la commande d'installation pour être certain que le module attend la fin de l’installation pour exécuter les autres commandes, et j'ai aussi revu l'ordre d’exécution de celles-ci, rien à faire, je pense donc que c’est un problème de droit (exécution depuis temp) puisque ça fonctionne parfaitement si je lance moi-même le reg situé dans le dossier ccsetup.

    CCleaner_maker_3.8b2.7z

  6. Justement, c'est exactement ce que fait le fichier .cfg créé par le maker, le fichier reg est fusionné après l'installation, mais ça ne fonctionne pas...

    Une fois le sfx créé, tu peux le lancer avec cet argument: -sfxconfig config.cfg ce qui permet de voir la config plus facilement:

     

    ;!@Install@!UTF-8!
    GUIMode="2"
    MiscFlags="4"
    RunProgram="hidcon:cmd /c \"FOR /f \"tokens=2*\" %G IN ('reg query \"hklm\\system\\controlset001\\control\\nls\\language\" /v Installlanguage 2^>NUL ^| FIND \"REG_SZ\"') DO SET /a \"_lcid=0x%H\" & CALL ccsetup.exe /S /L=%_lcid%\" >NUL 2>&1"
    Delete="%CommonDesktop%\\CCleaner.lnk"
    RunProgram="\"regedit\" /S ccleaner.reg"
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"UpdateCheck\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"Monitoring\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"SystemMonitoring\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"SystemMonitoringRunningNotification\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"CheckTrialOffer\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"PrefsPrivacyShareData3rdParty\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"HelpImproveCCleaner\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"UpdateNotify\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:reg add \"HKCU\\Software\\Piriform\\CCleaner\" /f /v \"UpdateAuto\" /t REG_SZ /d \"0\""
    RunProgram="hidcon:cmd /c schtasks /delete /tn \"CCleaner Update\" /f"
    RunProgram="hidcon:reg add \"HKCU\\Software\\Sysinternals\\Movefile\" /f /v \"EulaAccepted\" /t REG_DWORD /d 1"
    RunProgram="x64:hidcon:hidcon:cmd /c movefile \"%ProgramW6432%\\CCleaner\\CCUpdate.exe\" \"\""
    RunProgram="x86:hidcon:hidcon:cmd /c movefile \"%ProgramFiles%\\CCleaner\\CCUpdate.exe\" \"\""
    ;!@InstallEnd@!

     

  7. Hello,

     

    Je vais te répondre en français, ça sera plus simple.

    Pour ne rien arranger, ces deux "strings" sont traduite (avec une belle faute d'encodage sur la version 5.62.7538)

     

    image.png.51f22dc89aed88fc74c5c45a9fb612ae.png

     

    J'ai essayé de rajouter ces clés au maker, sans succès, je n'arrive d'ailleurs pas à les supprimer avec un fichier bat/cmd, uniquement avec un reg. Je pense que c'est lié à l'encodage.

     

    J'ai créé une version 3.8 beta avec les clés ajoutées à la fois au fichier reg et au fichier cmd, mais ça ne fonctionne pas...

    image.thumb.png.114f32973541996c0aa8e393c20909d8.png

     

    image.png.ff03f6eb8b26726e4c363171d70ad562.png

    Voici la 3.8 beta1 si tu veux tester: https://www.mediafire.com/file/1jb72t5wziczrqf/CCleaner_maker_3.8b1.7z/file

     

    J'ai aussi entièrement passé la création du fichier de config via le script, ça n'a pas été une mince affaire ^^

  8. Tiens, moi aussi j'ai enfin fait le saut sur 10, et je ne le regrette pas.

    J'ai profité de la réinstallation pour passer sur un SSD NVMe, et c'est clairement un cran au-dessus d'un SSD SATA, Firefox et Thunderbird s'ouvrent quasi instantanément, il y a moins d'une demie-seconde de délai entre le clic sur l'icône et le l'apparition effective de la fenêtre.

    Le système en lui-même me semble plus réactif que Windows 7, mais l'OS n'étant pas le même difficile de dire si c'est le passage à 10, le NVMe, ou tout simplement l'installation fraiche.

×
×
  • Create New...