Jump to content

Wrong start of WinToolkit Installer if KB2529687/KB2574819 integrated


Thiersee
 Share

Recommended Posts

If the two updates are integrated the WinTollkit Installer starts on the wrong time, as the windows installation is not yet ready (installation will be terminated)! Look at the picture.

Some errors comes frome some silent-installer and not all silent-sfx are installed (depending on your reaction time in hitting the OK-button).

This update are optional and have been offered yesterday by windows update; the issue is coming with v1.4.0.77 too.

Regards, Thiersee

Edited by Thiersee
Link to comment
Share on other sites

You've changed when the RunOnce installer runs, it runs after first logon not during installation (T-13).

I didn't change anything!

Yes, it should run after first logon, but if the mentioned updates are integrated with AIO, then it runs during installation; with v71 & v77 too (Installer 4.6.3).

Link to comment
Share on other sites

@Thiersee

Are you sure you spelled correctly KB2529687? What kind of update is this??? You mean KB2592687 right???

About KB2574819, please read the discussion here. It's related to this Remote Desktop new protocol. Both of them however won't install on my PC - Home Premium x86 - see here.

It's very likely they're compatible only with advanced-networking-features OSes, like Professional and Ultimate. What version of 7 were you trying to integrate those two into?

Edited by RicaNeaga
Link to comment
Share on other sites

@Thiersee

Are you sure you spelled correctly KB2529687? What kind of update is this??? You mean KB2592687 right???

Sorry, my error.

What version of 7 were you trying to integrate those two into?

Professional 64bit

I can integrate the updates, the problem is "only" the behavior of WinToolkit Installer, if this two updates have been integrated.

Without this , starts WinToolkit Installer after the first logon.

Link to comment
Share on other sites

I can integrate the updates, the problem is "only" the behavior of WinToolkit Installer, if this two updates have been integrated.

Without this , starts WinToolkit Installer after the first logon.

Sorry, but it sounds weird. Are you 100% sure the problem come from that two updates? Have you tried another build, with exactly the same preset/stuff added etc, but ONLY without those two updates and everything was fine?

Edited by RicaNeaga
Link to comment
Share on other sites

Sorry, but it sounds weird. Are you 100% sure the problem come from that two updates? Have you tried another build, with exactly the same preset/stuff added etc, but ONLY without those two updates and everything was fine?

Yes Sir!

v1.4.0.71, v1.4.0.77, v1.5.0.1_Test18: without tose two KBs no issue, with the issue in the picture.

I've just finish installing v1.4.0.77 (because of another problem) without this two KBs: no issue, the two updates comes later with Windows-Update.

I will try now 1.5.0.1_Test19 and will report, how it works.

P.S.: I install in a VirtualBox, no idea if this is important.

Edited by Thiersee
Link to comment
Share on other sites

http://support.micro....com/kb/2592687

To install the RDP 8.0 update, you must have hotfix 2574819 installed.

For more information about hotfix 2574819, click the following article number to view the article in the Microsoft Knowledge Base:

2574819 An update is available that adds support for DTLS in Windows 7 SP1 and Windows Server 2008 R2 SP1

I will sort that now ;)

EDIT: Done.

Link to comment
Share on other sites

I run just now again an installation:

v1.5.0.1_Test19

KB2574819 alone under tab "Updates"

no issue, all installed and running.

@RicaNeaga

So KB2592687 needs KB2574819.

I think that this is the problem!

If KB2592687 needs KB2574819 installed, it explains, on my opinion, the issue, because after integration-end the status for KB2574819 is "Install pending".

I could now try to integrate KB2592687 as last programm under Silent-Installer and KB2574819 under Updates, if you want.

Regards, Thiersee

Link to comment
Share on other sites

Your help in solving the problem would spare Lego to waste another time figuring out on his own. Whenever I have a problem I also investigate to the best of my knowledge. So it's great you're also dedicating some of your time in making Win Toolkit better. :)

Oh, and I don't want you to do anything. :D I never integrate such advanced networking / server-like additions / updates, as the two updates in question, since I never use those features, and like me I think there are 99% of users out there. :)

Link to comment
Share on other sites

And by test I mean to integrate them both again via AIO, with the next test build

You mean both under "Updates"?

Maybe you'll also have time to test Lego's next build, and see if his fix still generates issues for you or not.

Of course, Sir, I'll do it!

Edited by Thiersee
Link to comment
Share on other sites

Hi Lego,

now I have integrated/installed with Test 24B and the result is:

it is NOT enough only to sort KB2574819 at the top-level (prerequisite), it is also necessary to put KB2792687 unter Silent-Installer-SFX or to get this one later trough Windows Update).

Otherwise the error in first post comes again.

Link to comment
Share on other sites

Just encountered the behavior with 1.4.0.77...

I'm now testing the latest build of 1.5: test31. Will report in its thread.

Legolash2o: you should consider updating 1.4 (maintenance releases for bugfixes only) until 1.5 is stable enough for "everyday" use

Link to comment
Share on other sites

It may be a good idea for a simple and quick fix for both - 1.4 and 1.5 - to move KB2592687 by default when loaded to the silent installer category, as with KB2533552 (and other not integratable updates).

However, 1.5 looks very close to a final version to me, the only real pain-in-the-... in the probably .7z related issues (loading updates to the app, addon decompressing). Also, the changes in 1.5 are the wow factor. :)

But it is a complete mistery why would a ''simple'' update - KB2592687 - turn Win Toolkit upside down and behave in this manner. :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...