Jump to content

Unknown Mount Error (A required privilege is not held by the client)


Recommended Posts

Hi there I am fairly new to this but I'm not sure where I'm going wrong:


I'm trying to use the WIM Registry Editor to add in my own Reg tweaks into a windows 8.1 Pro x64 ISO and I get the following errors when trying to open the editor:




I click OK past that error and get then get this:




And once more after clicking OK past that I get this:




And that last one I can't close, I have to kill the process in task manager.


**NOTE** This also happens when I try to apply anything from within the All-In-One settings I get the same Unknown Mount error with the same details of 'A required privilege is not held by the client' - but I can click ok past it and it carries on applying settings (or that's what it looks like). However when I install the ISO on a virtual machine none of the changes are present.


I'm running Windows 7 Pro x64 on the host machine, and I'm trying to create a Windows 8.1 Pro x64 (With all the updates streamlined, as well as a few silent installs for the likes of Flash player, Java etc. - Also got a few addons for VLC player and 7Zip, plus a single themepack. - And as I said before also trying to add in my own registry tweaks.)


Thanks in advance.


Link to comment
Share on other sites

Whenever you are having such problems, the first thing I would suggest as a trouble shooting method would be to try it again except without any of the extra silent installs, only the updates.  If that works, then the problem is with on of the installs and you can try adding one at a time to successive attempts until it fails.  If updates only also doesn't work,  then I would try it again without any updates either, just to see if your basic building steps are right.  If that doesn't work either, then you have a fundamental problem with your building method.  It adding no updates work, then there is a problem with one or more of the updates.  There are some that cannot be integrated but must be added as silent installers so I would then find those and make sure you have not inadvertently tried to integrate them.


Bottom line, the best troubleshooting method is to make a simple build work then gradually add more and more to it to get it like you want, rather than trying to do it all the first time using a new tool.  Trying it all at once leaves too many possible sources of error to give you definitive advice if you have problems.  If you try the above, no matter what happens you will then have more information to report so that someone can quickly point you in the right direction.


Cheers and Regards

Link to comment
Share on other sites

Thanks for the advise so far, I've just tried the AIO integrator with only removing the Australian local pack (as it doesn't let me run if I haven't changed anything) - and I still got the exact same error.


I have a sneaky feeling it's either the ISO I'm trying to use, or there's some problems with permissions on my host machine.


I'm going to try again later when I get home (currently trying on my work machine) - with the same ISO, see if it's the machine.

Failing that I'll try another ISO.


If you have any other advice it's always welcome.


Thanks for your help.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Milan Moravec
      can not download Windows 10 - Redstone 3, bug 715-123130

    • By Lucas Salles
      I'm having a problem right after selecting the Windows version. The problem apparently is, no-internet-connection.
      Anyway, my connection is okay so... I need a hand here

    • By BusyElf
      I've researched the subject and have found almost all info needed to construct a batch command pipeline except how to get all keys from .reg file (or from command line) to get properly inserted into mounted subkey.
      I did found info about method involving running reg/regedit under desired user account, but i doubt it would work for user accounts inside wim and i also need to target key "HKU/.DEFAULT". I didn't test this.
      I have succeeded importing a hand-crafted .reg file into mounted subkey, but this would require me to manually alter all keys in .reg file so they get under required locations.
      If there is no other solution, i will try to put something together to partially automate this task.
    • By niTe_RiDeR_Pr0
      Hi Lego,
      I am trying to integrate the following updates (given in the log file and one more update KB2976978. There are total 30(with the error, specified in the log), + 1 (succefully integrated). all the failed updates show the following dism error: 0xc0000135. Here is the log file: http://pastebin.com/CqHrV1HS
      I had downloaded the updates from WHDownloader (Windows8.1-Update3-x64 update list), for my windows 8.1 enterprise (non-eval) x64 iso with update (en_windows_8.1_enterprise_with_update_x64_dvd_6054382.iso)
      Wintoolkit version is
      So how to fix this? Thanks 
      btw, i can't upload a log file as attahcment. why?
      thanks in advance.
    • By Lanu
      Hi, I am unable to remove C:\WinToolkit_Mount\ folder. It takes a lot space on my c: drive about 9 gigabytes.
      It says i dont have permission, even thought I am using admistration account(windows 7 x64).
      I tried bootable linux (puppy linux) from usb and it says "operation not supported or something" when I try to delete the folder.
      Any help  appreciated.
  • Create New...