Jump to content

[AddOn] Windows Sidebar v6.0.6002.18005


ricktendo
 Share

Recommended Posts

:censored: ing n00d antivirus deletes process.exe :ranting:

I will go back to tskill.exe i guess

EDIT: oic what you mean...i did not set it to copy (BTW slipstreamers are not affected)

Anybody else having problems with process.exe?

Should it stay or go?

6-19-08

- Fixed process.exe not being copied to system32 (only manual install was affected)

plz redownload

Link to comment
Share on other sites

I am doing fixed Turkish Language.

---------------------------------------------------------------------------------------------------------------------

; Localized Misc

LOC_NAME="Windows Kenar

Link to comment
Share on other sites

hi rick! i ran into a prob recently during start-up of the sidebar. prior to this everything has been smooth sailing for the longest time. i recently tried to add a gadget (Control System With Clock)& uninstalled it though the Add Gadgets screen. i think this was when the prob started. kindly see if you could help me on this pop-up:

A Runtime Error has occurred.
Do you wish to Debug?

Line: 180
Error: 'SettingsClosed' is undefined

thanks a lot!

Link to comment
Share on other sites

I am here for the very first time and I do not need even to tell you, how I am delighted that someone who really knows the job, doings something so great and desperately needed to wast majority of still Win XP or Win Srv 2K3 users... ~ Thank You!!!

Finally someone who really knows the job about all this quite specific project, doing so great... ~ Congratulations!!!

----

And now the problem:

I install everything as you instructed on 2 different test (clean install) PCs.

First PC has MSWinXPSP2 x86 (integrated / slipstreamed) + fully up-to-date over Windows Update Service (but not the MSWinXPSP3 Update)

Second PC has MSWinXPSP3 x86 (integrated / slipstreamed) + fully up-to-date over Windows Update Service

So, this both test PCs already has IE7, WMP11, all MS .NET Frameworks till v3.5 + all the Updates, fixes, etc.

I also install MS Visual C++ 2005 Redistributable Package x86, Wireless LAN API (KB918997).

Than Alky for Applications v1.1,

and than the Windows Sidebar v6.0.6001.18000.

During all this, I use a good old school, to do a PC restart after every of this successful installations, and than continue with other installation process as follows.

All this went quite quickly, easily, with no problems.

Eset Smart Security (ESS) did not inform me about any false Malware, well, his integrated bidirectional and professional Firewall ask me do I want to allow Inbound / Outbound Net traffic for the Sidebar, and this is completely OK, of course...

The only Gadget that it is not working is the Weather gadget, but, instead of that Gadget which has sometimes has even problem with working on legitimate Vista SP1 OS systems, I use MSN Weather Gadget instead, which working great and instantly with no problems at all.

My "Text Services and Input Languages" shows my "Default input language": Croatian, and all the "Installed Services" on both of mine test PCs,

are the Croatian and the second is English (United States) - US.

So what is my most primarily problem after all that I am written here...?

Well, I have one question.

I noticed this intriguing scenario on both of my mentioned test PCs.

I left both PCs engaged during 24h period, doing nothing on that PCs, but I earlier than this added even more Gadgets (just for this test purposes only), but only a default one from the Gadgets Gallery, so' no additionally and On-line Gadgets I did not use at all!!!

The Gadgets that I use are:

a) First Sidebar window: Clock, CPU Meter, Slide Show, MSN Weather, Calendar and the Recycle Bin.

B) Second Sidebar window: JoeJoe.org, Feed Headlines, Stocks, Currency, Vista Calculator, Notes, Network Utilization, DriveInfo.

c) Third Sidebar window: BBC Radio, Media Player, Windows Live Messenger.

After that (24h passes by...), in Windows Task Manager, the "sidebar.exe" processes (they are actually 2 or even 3 of them ~ depend how much Gadgets you input over the Sidebar...), rises the amount of memory usage in a sure way to higher level, decreasing it never until PC restart.

So', for example here:

a) First "sidebar.exe" is the most problematic, after few hours, or 24h, he can even use the amount of mem. usage from 100MB to even 350MB!

B) Second "sidebar.exe" shows the highest amount of mem. usage somewhere about 50MB.

c) Third "sidebar.exe" shows the highest amount of mem. usage somewhere about 30MB.

I repeat, the gadgets that I use, are the default one that comes instantly in the Gadget Gallery, so' no additionally and On-line Gadgets I did not use at all!!!

Than I try, just to disengaged all the Sidebar activated Gadgets, except the: Clock, CPU Meter, Slide Show, MSN Weather, Calendar and the Recycle Bin, and after that I have this bellow scenario, just after 1h of using this Sidebar, and not working at all on both of that PCs:

a) First "sidebar.exe" shows the highest amount of mem. usage somewhere about 24MB + still explicit rise with no stopping at all on some stable

number to much time along...

B) Second "sidebar.exe" shows the highest amount of mem. usage somewhere about 22MB. + stable mem. usage on the more-or-less equal number...

c) Third "sidebar.exe" are not existed any more, and this is OK.

You can figured now, that my question is, is all that normal?

I repeat that first "sidebar.exe" do not stopping, and the amount of mem. usage is strictly and explicit go higher and higher, no mater what.

So', if after 24h of PC working, the amount of mem. usage can rise all the way of even the 350MB for the first "sidebar.exe", how much will be after 2-3-5 days of PC working still on...?

-----------------

~ An again, thank you really and in advanced for any available information for this possible problem that you can provide up here!

I really appreciate, not only the help for my problem here and now, but as I said even before, the effort, work and time that you invest in all this great and terrific project in generally!

Just keep'n'goin' with the best regards from me!

Edited by Bruno.H.
Link to comment
Share on other sites

hi guys,

i am using a stripped version of windows vista ultimate which doesnt have sidebar... its completely removed, is there any way i can install sidebar manually and what files do i need? i tried to use this version, alky for xp wont install obviously because i am using vista... and i tried to just install sidebar.inf and it wont work....

any work around here?

please help/advise.

Link to comment
Share on other sites

Pink CPU Gadget Problem!

Start the windows sidebar just cpu gadget is pink color. But after run the messenger, or media player classic, or aver tv with cpu gadget normal transparan color. Why???

This PC System XP Pro SP3, IE7, WMP11.

Regards

Link to comment
Share on other sites

1) -----------------------------------------------------------------------

ok i install the sidebar,but i have problem,i cant open it i click on icon sidebar and nothing happend why?

can you help me please

nikola8 did you install Windows Sidebar Styler?

If so plz make sure you have .NET Framework 3.0 or 3.5

2) -----------------------------------------------------------------------

hello can you help me please

could you upload a addon where it only has the default gadgets (ones from vista) and with only the en_us locales or link me to it please

No Sorry, but if you want I can edit the INF for you so it only installs the default Gadgets

BTW the xx-XX (en-US) folder depends on the locale of your OS, the INF detects this automatically and installs the correct language gadgets and sub-folders

3) -----------------------------------------------------------------------

Bruno.H. more than one sidebar.exe process in taskmgr is normal, even happens on Vista

4) -----------------------------------------------------------------------

hi guys,

i am using a stripped version of windows vista ultimate which doesnt have sidebar... its completely removed, is there any way i can install sidebar manually and what files do i need? i tried to use this version, alky for xp wont install obviously because i am using vista... and i tried to just install sidebar.inf and it wont work....

any work around here?

please help/advise.

You need to rebuild your Vista CD.

Sorry Kelso, but you are mistaken...I have instructions on how to install the sidebar on Vista if it was taken out by vLite

Re-Install Sidebar on vLited Vista: http://www.msfn.org/board/install-windows-...wi-t115916.html

5) -----------------------------------------------------------------------

Pink CPU Gadget Problem!

Start the windows sidebar just cpu gadget is pink color. But after run the messenger, or media player classic, or aver tv with cpu gadget normal transparan color. Why???

This PC System XP Pro SP3, IE7, WMP11.

Plz post a screenshot atillag

Link to comment
Share on other sites

RE: Bruno.H. more than one sidebar.exe process in taskmgr is normal, even happens on Vista

Yes, affirmative, but is it normal that amount of mem. usage for just one sidebar.exe process in Task manager always explicitly rise, no mater what, use, after some 24h, even more than 350MB of mem. usage for just one sidebar.exe process, and there are even more and another two sidebar.exe process, that use another 30-50MB?!

So, you see the point, the amount of memory that use just one of the sidebar.exe process in task manager do not stay stable on some number (or in some normal amount of mem. usage), it rise all the way up without any real and permanently stopping...

I wonder, what will happen if I left my PC engaged for a few days - the amount of mem. usage for just one sidebar.exe will be..., I do not know, the 2000MB or similar number...?!

That's worries me actually, and that is my major question here is that normal scenario...?

An again, thank you for your Reply!

post-9389-1214342464_thumb.jpg

Edited by Bruno.H.
Link to comment
Share on other sites

No Sorry, but if you want I can edit the INF for you so it only installs the default Gadgets

BTW the xx-XX (en-US) folder depends on the locale of your OS, the INF detects this automatically and installs the correct language gadgets and sub-folders

That would be great

@ Bruno H how many gadgets you got open?

Thanks

Richard

Edited by Richardarkless
Link to comment
Share on other sites

1) ----------------------------------------------------------------

That would be great

@ Bruno H how many gadgets you got open?

Thanks

Richard

Here is the INF that will only install default sidebar gadgets (add any other ones you want to Gadgets.exe in svcpack)

http://www.mediafire.com/?imis1btybt2

BTW what locale does the sidebar install your MUI and Gadget sub-folders to?

It should install them to whatever it says when you open a CMD window and type LCID and hit enter

2) ----------------------------------------------------------------

hey ricktendo64

thanks a lot for ur prompt reply. but i need some more help bud!!

i donno how to extract data from install.wim

what apps do i use and what is the process of extracting windows sidebar folder?

please help...

thanks again.

7zip...Just right click on install.wim and choose 7zip->Open archive, now look in one of the numbered folders and in there you will see Program Files, Windows etc

Go in Program Files and drag & drop Windows Sidebar dir onto your desktop or somewhere, follow my instructions and done

Link to comment
Share on other sites

1) ----------------------------------------------------------------

Here is the INF that will only install default sidebar gadgets (add any other ones you want to Gadgets.exe in svcpack)

http://www.mediafire.com/?imis1btybt2

BTW what locale does the sidebar install your MUI and Gadget sub-folders to?

It should install them to whatever it says when you open a CMD window and type LCID and hit enter

Thanks all is great now

it installs it to en-gb

Link to comment
Share on other sites

RE: @ Bruno H how many gadgets you got open?

I already described all fully detailed scenarios on both of my test PCs, that are just (re)built for this Vista Sidebar testings...

It is not a problem for me to write again all that at all, but, I already wrote all this in my very first and huge post, so, if you will be kind enough to read it.

It is a quite huge and boring text, I know, but in there I described everything in very specific detailed and step-by-step order, how I got this huge amount of mem. usage in the first place, so you can repeat the test on your own if you might need it.

Right now, they are only 6 of the Gadgets engaged only on the first Sidebar view.

But, in the first try, and just for this testing purposes only, I put Gadgets on all 3 Sidebar views, and they was 16 totally engaged, all in the same time (even more you can carry out to fulfill the all 3 Sidebar views in fully / max.)!!!

I repeat, now they are only 6 of them, just on the very first Sidebar view...

It is also important that all the gadgets that I use in both scenarios, and in both test PCs, was only those available by default in the Sidebar Gallery and no other Gadgets from the Net, for e.g., was not added at all!!!

I specifically named all those engaged Gadgets (specifically by exact Gadget name, which one was engaged before, and which are actually engaged right now), and how all that Gadgets was rearrange on all 3 Sidebar views in my very first, huge and detailed post here, so I think again, that it is important to read it fully to understand all the problem that I mentioned here.

I am an IT Security expert for more than 12 years, working with the PCs about 20 years in generally. I have a huge business opportunity to test wast amount of numerous Software on more than 50-80 different test PCs, so, for just this Vista Sidebar purpose, I use just the two test PCs only, and I can put them on that stage for a few more days if needed here, or I can also help / contribute / improve... :-)

Thank you once more for help and all the effort;

Best regards!

Edited by Bruno.H.
Link to comment
Share on other sites

7zip...Just right click on install.wim and choose 7zip->Open archive, now look in one of the numbered folders and in there you will see Program Files, Windows etc

Go in Program Files and drag & drop Windows Sidebar dir onto your desktop or somewhere, follow my instructions and done

u r a true master my friend! ur tips works like a charm!

thanks very much!

long live rick!

Link to comment
Share on other sites

And here are the results for today - I left all test PCs all night long fully engaged and on-line:

1. I even put last night the 3rd test PC in action all here, with the whole 16 Gadgets on MSWinVistaSP1 x86 (integrated / slipstreamed) + fully up- to-date over Windows Update Service, and after 11h passes by, I got today this scenario picture here:

a) First sidebar.exe shows amount of mem. usage in Task manager: 19.332K (very stable number)

B) Second sidebar.exe shows amount of mem. usage in Task manager: 2.644K (very stable number)

c) Third sidebar.exe shows amount of mem. usage in Task manager: 2.131K (very stable number)

2. But, on MSWinXPSP3 x86 (integrated / slipstreamed) + fully up-to-date over Windows Update Service, and that has all the 16 Gadgets engaged thru last night, I have this scenario today:

a) First sidebar.exe shows amount of mem. usage in Task manager: 520.712K (and keep rising) !!!

B) Second sidebar.exe shows amount of mem. usage in Task manager: 104.744K (and keep rising) !!!

c) Third sidebar.exe shows amount of mem. usage in Task manager: 17.020K (and keep rising)

3. At last, on a PC with MSWinXPSP2 x86 (integrated / slipstreamed) + fully up-to-date over Windows Update Service (but not the MSWinXPSP3 Update), and that has only 6 Gadgets engaged thru last night and not the bunch of 16, I have this scenario today:

a) First sidebar.exe shows amount of mem. usage in Task manager: 129.712K (and keep rising) !!!

B) Second sidebar.exe shows amount of mem. usage in Task manager: 73.744K (and keep rising) !!!

c) Third sidebar.exe shows amount of mem. usage in Task manager: 11.020K (and keep rising)

Conclusion:

On the third and totally new test PC here, with the "real" MSWinVistaSP1, the amount of mem. usage for bunch of all the 16 engaged Gadgets stays all night long on some stable number of mem. usage for all 3 sidebar.exe process with maximum peak on about 25MB of mem. usage of the highest sidebar.exe process.

On previous two test PCs here, that has MSWinXPSP2/3, the amount of mem. usage keep, and keep exponentially rising, no mater if I put 6 or 16 Gadgets - it does NOT mater, it always rising without stopping or staying too long on some stable mem. usage number!

The only relevant difference here is that number of just the 6 engaged Gadgets here, will need much longer time to rise to 500MB of mem. usage amount for sidebar.exe process in Task Manager, than the scenario when you use a bunch of 16 engaged Gadgets here, and this is all...

Edited by Bruno.H.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...