Jump to content
ricktendo

Windows 7 says I have 3 but only 2.75 GB of ram are usable

Recommended Posts

Guest

well i remember i read that it's 32 bit limitation

that 32 doesn't read all the ram when it's 3 giga or higher

so if you are more than 3 go to 64 bit it should work fine

Share this post


Link to post
Share on other sites

Yes Dark Madness is right 32bit Win7 can only Support 3 GB as Maximum. I think it is also depend on horse power of CPU. How effectively it process ram.

Edited by Jatin Beniwal

Share this post


Link to post
Share on other sites
Guest

3.25 is the 32 bit limit.

well not always 32 bit should read the almost the 4 giga as it's limit is 4

but look at this link

well i don't know what is the problem but the most thing that is in common that it's a 32 bit limit

edit :

i also read that the sound some times takes from the memory

that is one that have a shared vga and 4 giga memory

3.5g

-.5 Graphics

= 3.0

- .25 for sound, and other add-on cards gives

= 2.75

Edited by DaRk MaDnEsS

Share this post


Link to post
Share on other sites

If you want to see a breakdown of memory usage, run resmon (Resource Monitor). As of RC1 it breaks down where all of your installed memory is allocated, even showing what is taken by hardware.

Share this post


Link to post
Share on other sites

I have installed Windows 7 RTM on my laptop with 4gb of RAM and I think it displays a little more than 3.25 as available (still not the whole 4gb)...

I'm also thinking about migrating to x64 when I buy my copy of Win7 for the desktop.

Share this post


Link to post
Share on other sites

Yes, that is because 32-bit systems cannot allocate whole 4GB. You can use the PAE switch in your boot.ini file but that's not a lucky solution either.

As you said, the best way would be to go with 64-bit version.

Share this post


Link to post
Share on other sites
Guest

Check it out Here!

well the problem is not that

the Ram are 3 not 4

it didn't get the limit

so i think it's not the problem

Share this post


Link to post
Share on other sites

I only have integrated sound, no grafix at all

What vid card do you use? Quite a few low-end vid cards use shared ram for their memory. Even if not integrated video.

Share this post


Link to post
Share on other sites

for x64 architectures:

go in ure bios, then in the advanced/memory options; disable the memory hole mapping.

for x86;

ure screwed!

Share this post


Link to post
Share on other sites

You could always run resmon and make sure it is being flagged as "hardware reserved" - if so, you'll at least know it's the BIOS (and probably your onboard video).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...