Jump to content

Windows 7 Toolkit v0.8.0 Requests + Alpha


Legolash2o
 Share

Recommended Posts

  • Replies 204
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Mh just remembered a old tool, might be nice if you could add a WIM to VHD feature, WIM2VHD does this, maybe you can integrate it into w7t? though the wsf script would need some modifications as it does not support spaces (though not sure as it seems i tested a old version)

Converting took about 7-8 Minutes complete, Booting takes a few minutes too as it needs to configure itself cause Drivers etc arent installed yet.

Still pretty much faster than Creating a ISO, Creating a VM in VirtualBox or VMWAre etc, Load the ISO there, Boot, Chose stuff, Install.. Wait.

Link to comment
Share on other sites

Just wondering Legolash2o, are you now actually working on adding a Working Log (commands listed etc)? not just a Error log. So we can finally see why things might not work etc, it doesnt have to error out to not work proper.

Edited by Mand
Link to comment
Share on other sites

Hi am new here to the board... I really enjoy the software, I just started to use it last week.

Although I have been having trouble with the toolkit since, not sure if anyone has been having the same trouble, I looked all over the place to see..

The file attached has the errror message,

I used version 2a, 3a and 5a of the toolkit, so I don't think it is on my end, I started with a clean copy of Windows x86 and added the M$ updates from the list of http://www.softwarepatch.com/windows/index.html

http://www.softwarepatch.com/windows/windows-7-security-updates-2009.html and

http://www.softwarepatch.com/windows/windows-7-security-updates-2010.html

I did not use the beta update packs from M$.

My suggestions for the next release wouold be able to change the junction points or add a fake juction point to the following...

Program Files, Users folder, Temp folder.

I did this with Windows XP and because I partitioned the drives the hard drive performance was always 150-300% faster in reading and writing files in NTFS format not to mention Scan disc and defragging the drives were muich faster too, I could set it up to defrag drive D and go to lunch and come back and it would be waiting for me to do something.

Thanks for your help.

post-11461-082021700 1283309960_thumb.jp

Edited by hgary1
Link to comment
Share on other sites

Just wondering Legolash2o, are you now actually working on adding a Working Log (commands listed etc)? not just a Error log. So we can finally see why things might not work etc, it doesnt have to error out to not work proper.

I will be adding "Default Logging" and "Extensive Logging". Default: Just basic information about what's been done, etc..Extensive: Will show alot more i.e. If a command runs, and will show reasons why things failed.

Hi am new here to the board... I really enjoy the software, I just started to use it last week.

Although I have been having trouble with the toolkit since, not sure if anyone has been having the same trouble, I looked all over the place to see..

The file attached has the errror message,

I used version 2a, 3a and 5a of the toolkit, so I don't think it is on my end, I started with a clean copy of Windows x86 and added the M$ updates from the list of http://www.softwarep...dows/index.html

http://www.softwarep...dates-2009.html and

http://www.softwarep...dates-2010.html

I did not use the beta update packs from M$.

My suggestions for the next release wouold be able to change the junction points or add a fake juction point to the following...

Program Files, Users folder, Temp folder.

I did this with Windows XP and because I partitioned the drives the hard drive performance was always 150-300% faster in reading and writing files in NTFS format not to mention Scan disc and defragging the drives were muich faster too, I could set it up to defrag drive D and go to lunch and come back and it would be waiting for me to do something.

Thanks for your help.

Ok fixed that error and should be in the next alpha which i will release soon.

Thanks for the links, look very useful :)

What are junction points? thanks

Edited by Legolash2o
Link to comment
Share on other sites

v6 is out, with a total of 59 changes in the change log, 0.7.0 only had 46. LOL it's only on build 6 and it's already passed 0.7.0 :D

v20 will be BETA

v40 will be RC

v50 will be Final

http://www.mediafire.com/Legolash2o

*Options now save settings when clicking apply

*W7T detects when the mount window is closed

*New Logging (Default and Extensive)

*Fixes Unmount error

*Component Remover removes more language files.

Edited by Legolash2o
Link to comment
Share on other sites

Hi!

VERY BIG BUGS !!

Component removal not work. Everytime when i am removing some component and trying close this wonderfull program coming error :

HELP ME PLS!

My OS is Windows 7 -64bit Ultimate. And Clean original Install.

" See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Security.SecurityException: Requested registry access is not allowed.

at Microsoft.Win32.RegistryKey.InternalOpenSubKey(String name, RegistryKeyPermissionCheck permissionCheck, Int32 rights)

at W7Toolkit.frmCR.frmCR_FormClosing(Object sender, FormClosingEventArgs e)

at System.Windows.Forms.Form.WmClose(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

The Zone of the assembly that failed was:

MyComputer

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4952 (win7RTMGDR.050727-4900)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll

----------------------------------------

W7Toolkit

Assembly Version: 0.8.0.6

Win32 Version: 0.8.0.6

CodeBase: file:///C:/W7T080-6A/W7Toolkit.exe

----------------------------------------

Microsoft.VisualBasic

Assembly Version: 8.0.0.0

Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Runtime.Remoting

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

----------------------------------------

System.Configuration

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

MySql.Data

Assembly Version: 6.3.2.0

Win32 Version: 6.3.2.0

CodeBase: file:///C:/W7T080-6A/MySql.Data.DLL

----------------------------------------

System.Data

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_64/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

System.Transactions

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_64/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll

----------------------------------------

System.Management

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll

----------------------------------------

System.EnterpriseServices

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_64/System.EnterpriseServices/2.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box."

Edited by TH-TECH
Link to comment
Share on other sites

That's a strange error, because the error mentions the registry but... There is no code which asks for the registry or anything to do with the registry when that form is closing. Open regedit HKey Local Machine, is here any random keys (folders) in there which wouldn't be. Check before closing the component remover.

I will check everything when I get home from work, but an idea of what it is has just popped up in my head. Check back around 9PM BST (UK) time 2nite

EDIT: I have remember how I did it, what an idiot (me). I will fix it straight away when I get home LOL.

Edited by Legolash2o
Link to comment
Share on other sites

That's a strange error, because the error mentions the registry but... There is no code which asks for the registry or anything to do with the registry when that form is closing. Open regedit HKey Local Machine, is here any random keys (folders) in there which wouldn't be. Check before closing the component remover.

I will check everything when I get home from work, but an idea of what it is has just popped up in my head. Check back around 9PM BST (UK) time 2nite

EDIT: I have remember how I did it, what an idiot (me). I will fix it straight away when I get home LOL.

Thank you!

Sorry my Bad Bad English! I am only a Finnish Boy ( R

Link to comment
Share on other sites

E1.PNG

After that: The package is 'gone' in the List, can't close Component Remover, getting some Premission Error basicly the same as already Posted ^_^ with the Registry

Edited by Mand
Link to comment
Share on other sites

As promised a fix for the bug has been released in v7. This release was specifically released for that bug.

http://www.mediafire.com/Legolash2o

Everything is WAU!

IT WORX WERY WELL!!

Thank You!

Now i can make nice windows image! Thank you. Good job !!

Obs!

But if i remove some language files that not delete to LIST. image size is same.

WAU !

Edited by TH-TECH
Link to comment
Share on other sites

Are you saying that if you remove language files, nothing else can be removed?

No!

IIS, system restore etc. removed the list fine. Language files is the list. I removed all language files ( Not Finnish) but image size is same and language files is the list.. If i removed like tablet pc components image size change and tablet components removed the list.

Sorry my English!

Link to comment
Share on other sites

v8 released with LP removal fix.

A lot has changed since v5... v5 just removed folders which contains stuff like ar-SA, bg-BG, da-DK,de-DE, etc... whilst v6+ removed files containing those characters, alot of files...

@Mand.

The error about PremiumInbox games is because when you removed "Inbox Games" it also removes Internet Games and Premium Games, so when it comes to premium games its already been removed and therefore says it dont exists :)

I have already entered a code which will mean it will not display an error in that scenario for v9.

Edited by Legolash2o
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...