Jump to content

Can't delete WinToolkit_Mount folder


Recommended Posts

Hi, I am unable to remove C:\WinToolkit_Mount\ folder. It takes a lot space on my c: drive about 9 gigabytes.


It says i dont have permission, even thought I am using admistration account(windows 7 x64).


I tried bootable linux (puppy linux) from usb and it says "operation not supported or something" when I try to delete the folder.


Any help  appreciated.



Link to comment
Share on other sites

Hi, it doesnt show in wim manager anymore. The folders inside wintoolkit_mount are program files, program files (x86) and windows. Wintoolkit never close properly, it hangs writing on temp folder. I have to force it to close.

Link to comment
Share on other sites

  • 9 months later...

Hi there!


I know this is quite old topic but I had the same problem. So here is my story


I think the problem occured when I mounted wim-file in WIM editor but did not unmount it after changes but closed WTK. Then I deleted the mount folder and there were couple of left behind. I tried deleting these leftovers with killbox, linux live cd etc. but nothing worked. After many hours of googling different solutions to delete "locked" filesI finally got together this method and it did work:


First you must change the owner permissionf of "damaged" mount folder:


Right-Click the folder -> Properties -> Security tab -> Advanced button -> Owner tab -> Edit button -> Select your user account -> Activate Replace owner on subcontainers and objects.

When done, close all properties windows and open Properties again -> Security tab -> Advanced button -> Permissons tab -> Change Permissons button -> Add your user account and select Replace all child object...


Then open command promt with administrator priviledges ( https://technet.microsoft.com/fi-fi/library/cc947813%28v=ws.10%29.aspx )

Type the following and press enter:

DISM /Cleanup-Wim

Now you should be able to able to delete all leftover files/folders.


Best regards


Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...