Jump to content
user_hidden

[Addon] Microsoft .NET Framework AIO ROE x86 - 20131008

Recommended Posts

Microsoft .NET Framework AIO ROE x86 - 20131008

includes:

dotNet Framework 2.0 SP2

KB958481 - Application Compatibility Update

KB976569 - Update for the .NET Framework 2.0 SP2 forward compatibility

KB976576 - Rollup Update

KB976765 - ASP.NET update

KB980773 - NCL update

KB2604092 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2729450 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2742596 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2789643 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2833940 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2836941v2 - Compatibility and Reliability Update

KB2844285v2 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2863239 - Vulnerabilities in .NET Framework Could Allow Spoofing

dotNet Framework 3.0 SP2

KB958483 - Application Compatibility Update

KB976570 - Forward Comptibility Update

KB976769 - WCF update

KB977354 - This update will disable the Web Browser ActiveX control (WebOC) when running WPF XAML Browser Applications (XBAPs) in the Firefox browser in partial trust

KB2756918 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2832411 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2861189 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

dotNet Framework 3.5 SP1

KB953595 - The Visual Basic compiler (Vbc.exe) may use 100 percent of the CPU resources when you build a .NET Framework 3.5-based application that has many assemblies and references

KB958484 - Application Compatibility Update

KB960043 - Dual Branch Servicing

KB963707 - Framework Assistant 1.0 for Firefox

KB982306 - ADO.NET Data Services Update

KB2604111 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2736416 - Vulnerability in Open Data Protocol Could Allow Denial of Service

KB2836940 - Compatibility and Reliability Update

KB2840629 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2861697 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

Other Updates

KB951847 = Microsoft .NET Framework 3.5 Family Service Pack 1

KB959209 = KB958481 + KB958483 + KB958484

KB971276 - You receive incorrect print output if the IPrintPipelineProgressReport interface is used in your printing application

dotNet Framework 4.0 Client Profile

KB2468871 - Update for the .NET Framework 4

KB2533523 - Microsoft .NET Framework 4 Reliability Update 1

KB2600217 - Microsoft .NET Framework 4 Reliability Update 2

KB2604121 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2656351 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2729449 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2736428 - Vulnerability in Open Data Protocol Could Allow Denial of Service

KB2737019 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2742595 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2789642 - Vulnerabilities in .NET Framework Could Allow Elevation of Privilege

KB2804576 - Vulnerabilities in .NET Framework Could Allow Spoofing

KB2832407 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2835393 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2836939v3 - Compatibility and Reliability Update

KB2840628v2 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution

KB2858302v2 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

KB2861188 - Vulnerabilities in .NET Framework Could Allow Remote Code Execution

note: if you get nagged by MU/WU for KB961118 and/or KB971314 use my Post-SP3 update pack

or one that does include them. XPSP3_QFE_UpdatePack for Windows XP Post-SP3 (user_hidden)

WIC and MSXML6 have been removed from the installer but is of no issue as they are included in Windows XP SP3.

===================================

Addon for RVMi 1.6 or higher.

Integrate this addon to run the installer at RunOnceEX.

There will be progress boxes but NO user interaction is required.

Passive mode is used since setup takes a while, this way you will know

where you are in the setup process. Final installation will take

place after OOBE and before Personalized settings occur.

Link: Addon_Microsoft.Net_AIO_ROE_20131008.7z

CRC-32: 7a0df040

MD4: c54fd5f6d5de102eaa95b9ca68017687

MD5: 845bbb1c60de66df547a715af2e8a9cd

SHA-1: 4af2cae8a7f2411a222e005d715dcc3ad51d94f9

Date: 20131008

OS: Windows XP SP3 (x86)

Size: 53.9 MB

If you unpack the Addon to get access to the multimode installer you'll have access to the following switches:

-ai = Silent

-ai1 = Passive

/h = displays help

===================================

Some utilities:

Aaron Stebner's .NET Framework Cleanup Utility

Aaron Stebner's .NET Framework Setup Verification Tool

dotNetFWVersionChecker.exe - .NET Framework Setup Verification Tool

Free DotNet VersionCheck Utility

===================================

Edited by user_hidden

Share this post


Link to post
Share on other sites

really nice work - was actually looking for this :thumbsup_anim: .

and just in time for xmas, how timely.

I'm putting this baby under the tree.. :worthy:

you rogue spears devotees..are so cool. happy holidays to you and your folk.

and again thank you..!

Share this post


Link to post
Share on other sites

updated 20110427 ....

added an addon for .Net Framework 4.0 Extended

Wish you have included dotnet framework 1.1 also in your AIO pack :) It's the only one missing. Any special for omitting it?

Thx and regards

Share this post


Link to post
Share on other sites

Wish you have included dotnet framework 1.1 also in your AIO pack :) It's the only one missing. Any special for omitting it?

Thx and regards

net 2,3,3.5,4 install from runonceex while my net 1.1 installs from svcpack.

if you want my dotnet 1.1sp1 package it is posted here:

Share this post


Link to post
Share on other sites

net 2,3,3.5,4 install from runonceex while my net 1.1 installs from svcpack.

if you want my dotnet 1.1sp1 package it is posted here:

Thank a lot for replying user_hidden. I "am" actually looking for AIO .Net framework addon. Which contains updated versions of all the frameworks, from 1.1 to 4, and can easily be integrated with nlite on XP SP3. Do you know one such addon?

Gracias :)

Share this post


Link to post
Share on other sites

Kindly fix the .net framework 4.. There is an error pop-ups regarding .net framework 4..

What error? This addon works perfect for me.

Do you mean these Event viewer errors?

post-3472-0-81693400-1309779613_thumb.pn

Edited by Mr_Smartepants

Share this post


Link to post
Share on other sites

Kindly fix the .net framework 4.. There is an error pop-ups regarding .net framework 4..

please explain exactly your issue.

how do you integrate this addon and with what update pack and other addons?

maybe show us an image of the error so some help may come your way.

this installer has been extensively tested and works as it should.

and as a note this is for WINDOWS XP x86 - any other OS install is NOT SUPPORTED !

Edited by user_hidden

Share this post


Link to post
Share on other sites

please explain exactly your issue.

how do you integrate this addon and with what update pack and other addons?

maybe show us an image of the error so some help may come your way.

this installer has been extensively tested and works as it should.

and as a note this is for WINDOWS XP x86 - any other OS install is NOT SUPPORTED !

i integrate this addon + .net framework 1.1 using rvm integrator.. my copy is an Windows XP Professional SP3 x86 (clean)..

the error pop-up after installation of .net framework 3.5 sp1..

Edited by DaRkSe7eN

Share this post


Link to post
Share on other sites

i integrate this addon + .net framework 1.1 using rvm integrator.. my copy is an Windows XP Professional SP3 x86 (clean)..

the error pop-up after installation of .net framework 3.5 sp1..

what is the error ?

Share this post


Link to post
Share on other sites

i integrate this addon + .net framework 1.1 using rvm integrator.. my copy is an Windows XP Professional SP3 x86 (clean)..

Are you sure you're using SP3?

WIC and MSXML6 have been removed from the installer but is of no issue as they are included in Windows XP SP3.

Make sure you're not removing WIC after all the integrations are completed.

Edited by Mr_Smartepants

Share this post


Link to post
Share on other sites

@DaRkSe7eN

make sure that your source is ORIGINAL SP3 100% and not some image that you think may be "real" or "clean"

......WIC is included with SP3 and so is MSXML6.

I've tried to installer it manually the .Net Framework 4.0 manually.. and successfully installed it without any problems at all.. Client profile and extended..

maybe your .net framework update doesn't match on my Windows XP Pro SP3..

Share this post


Link to post
Share on other sites

Yes, it's your Windows XP Pro SP3 that doesn't match this addon. And this addon matches XP Pro SP3 very well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...