Jump to content

[Slim] .NET Framework 4 Full x86/x64 (1-10-2016)


ricktendo
 Share

Recommended Posts

Hi!

Thanks for reuploading.

I integrated 395 updates and 2 silent installs. Look at the image:

http://postimage.org/image/sa7l8h3cf/full/

After windows installation , before installing framework 4 and  before installing framework 5 it appeared this:

http://postimage.org/image/xmwfmlr8v/

During framework 4 installation it appears this error:

http://postimage.org/image/azh6ggbov/

Installtion of framework 4 failed

What I am doing wrong, the silent commands are bad?

Is it bad that at syntax i put "dotNetFx40_Full_x86_x64_Slim.exe /y"?

I am not good at his kind of stuff

Link to comment
Share on other sites

When during the setup process does the install happen?

 

1st boot? audit?

 

BTW don't integrate 4.0 along with 4.5, you only need 4.5

 

And your cmd line is right, /y or /ai will get the job done

 

Edit: if you are still experiencing issues try the rebuilt, its the same as the default .net 4.5 installer but it has updates and the MZZ is better compressed to save space (run installer with /? to view command line options)

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I mean that the .net framework 4 and 4.5 breaks Windows Update on some systems. It's a well known defect

 

http://superuser.com/questions/555714/installing-net-framework-4-client-profile-breaks-windows-update

It might be a "well known defect", but you should look at the solution that was presented.

 

 

This seems to have done the trick. I un-installed .Net Framework 4 Client Profile (to be absolutely sure), rebooted and then installed .NET Framework 4.5. Interestingly Microsoft deprecated the client profile in 4.5 so all you have is the full version. So far Windows Update has continued to work, fingers crossed! – Richard Feb 24 at 11:18

 

 

Just install the full version of .net 4.5 (not just client profile).

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

If we want add a Slim Language Pack inside Slim Microsoft .NET Framework 4.0 Full x86/x64, it seems we don't need now to add kb971891 for dotNET4 & LP installers
using:
Slim down your dotNET4(.5) & LP installers:
http://adf.ly/1713566/msislim (msi.vbs.slimmers)

 

Also, inside netfx4+lp_slim.vbs we can read:

' Usage:
'
' - Create administrative install and integrate KB971891:
'
' msiexec /a <netfx_installer>.msi /p NDP40-KB971891.msp TARGETDIR=<path_to_folder>
'
' - Make sure netfx*.msi and DisplayIcon.ico are in the same directory as this file before running:
'
' cscript <name_of_file>.vbs
'
' - Create second administrative install to leave the setup files behind:
'
' msiexec /a <netfx_installer>.msi TARGETDIR=<path_to_new_folder>
'
' Note: if you don't do this second admin install you have to manually set the MSI Summary Information to: Administrative Image + Long File Names
'
' script by dumpydooby (modded by ricktendo64)

 

 

Thanks and regards

Link to comment
Share on other sites

No, if you download the LP I made all that (kb971891 & slimming) is already done

Just download the installer, then the lp and extract them to the same directory. Recompress and download the INTL SFX maker, you will need to edit this to remove all the sfxlang sections and fix the LP msi name without the lang at the end of the filename xx-XX. (keep sfxlang:1033 and whatever lang you are adding)

Link to comment
Share on other sites

No, if you download the LP I made all that (kb971891 & slimming) is already done

Just download the installer, then the lp and extract them to the same directory. Recompress and download the INTL SFX maker, you will need to edit this to remove all the sfxlang sections and fix the LP msi name without the lang at the end of the filename xx-XX. (keep sfxlang:1033 and whatever lang you are adding)

 

Thanks Rick,

I was thinking that the kb971891 was already integrated, and I use dotNET4sfxNoGUI according to your recommendations

above (extracted inside the same directory) and works fine for me!

 

Regards

Link to comment
Share on other sites

tested and working under Windows XP SP2 x64 however i made the .exe with Add On Maker and added the file under nLite but it still prompted me to click "next" using command /quiet /norestart

 

Note i only had 256MB RAM inside VM Box and wouldnt let me install it (it should but didnt really wonted to task the risk) microsoft webste says;

 

Pentium 1 GHz or higher

with 512MB RAM or more

 

So if you have an older PC make sure it you have 512MB RAM and a P4 1.0GHz or higher

:)

Edited by francisuk
Link to comment
Share on other sites

Hello all ... I have a little problem ... certainly this question has been asked many times who knows .. I want to create the net4 with LPita ... I have:
-extract the file dotNetFx40_Full_x86_x64intl_Slim
-extract the file dotNetFx40LP_Full_x86_x64it_Slim
-I copied the contents of the extracted file dotNetFx40LP_Full_x86_x64it_Slim in the folder dotNetFx40_Full_x86_x64intl_Slim
After I archived with 7zip files in the folder dotNetFx40_Full_x86_x64intl_Slim
I have download and extract the file dotNET4sfxMaker5

is it correct?

And now?
thanks thanks thanks

sorry but I do not have a good English

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...