Jump to content

Recommended Posts

It has taken me considerably longer to track down a couple of bugs, but I have found the problems. I have not finished the update. I hope to have it posted tonight.

Share this post


Link to post
Share on other sites

I have nearly completed the update. I need some information from anyone that does not have english as their Windows language. When you right click on a exe or file, on the context menu, there is a choice to pin to taskbar. I need to what what the exact string is to pin to the taskbar. On english systems it is "Pin to Taskbar". Note, the string must be exact or it will not work.

The sooner that you can get this to me, the sooner I can incorporate it into the script.

Windows 7 has given me trouble in copying files, reading reg strings, creating shortcuts. I finally have it all worked out. The new version works in all versions of windows (xp and up) and the installer package will install in any version of windows (xp and up) 32-bit or 64-bit, silently. The script will only need to be run as admin if you have your folders\files hidden as the script needs to see hidden folders to copy from the profile and the script can change the reg setting to view hidden files.

The install package does not need UAC to be disabled or to be run as admin. You will, of have to respond to the nag screen.

I still have a few things to cleanup, but I should have it ready in a few days. Sorry, I only have a couple of hours a day to work on this.

***EDIT***

Does this path remain the same?

"Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"

Edited by Jonnyboy

Share this post


Link to post
Share on other sites
Guest

I have nearly completed the update. I need some information from anyone that does not have english as their Windows language. When you right click on a exe or file, on the context menu, there is a choice to pin to taskbar. I need to what what the exact string is to pin to the taskbar. On english systems it is "Pin to Taskbar". Note, the string must be exact or it will not work.

The sooner that you can get this to me, the sooner I can incorporate it into the script.

Windows 7 has given me trouble in copying files, reading reg strings, creating shortcuts. I finally have it all worked out. The new version works in all versions of windows (xp and up) and the installer package will install in any version of windows (xp and up) 32-bit or 64-bit, silently. The script will only need to be run as admin if you have your folders\files hidden as the script needs to see hidden folders to copy from the profile and the script can change the reg setting to view hidden files.

The install package does not need UAC to be disabled or to be run as admin. You will, of have to respond to the nag screen.

I still have a few things to cleanup, but I should have it ready in a few days. Sorry, I only have a couple of hours a day to work on this.

***EDIT***

Does this path remain the same?

"Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"

if you mean this

%appdata%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\

then yeah it's the same

and hope your addon maker gets out soon

Share this post


Link to post
Share on other sites

if you mean this

%appdata%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\

then yeah it's the same

and hope your addon maker gets out soon

in languages other than english is the question.

Share this post


Link to post
Share on other sites

@Jonnyboy

Hi

I am using your addon since ever and I find it very useful. But using the las two versions I stumbled upon a few problems.

First, a question or two.

What is with this function "Addon Installation Paths" "Click to enter the Addon's Destination folder of your choice, or you can create a new folder.". I don't want to enter a new folder for the addons, I want to use the default path. What is the default path? c:\Program Files\Mozilla Firefox or the profile path C:\Documents and Settings\Andrei\Application Data\Mozilla\Firefox\Profiles\random_name.default By default, in your tool is entered C:\Program Files\Firefox. If that is set,will FF install there instead of c:\Program Files\Mozilla Firefox\ ?!?!

I just reinstalled XP today and ran FF silent built with your addon maker and it failed to install fully. I had to install the original Firefox Setup 3.6 Beta 1 over the first installation so I could open FF. Bad thing is that all my addons were gone. Good thing is that all the bookmarks were there. That was a life saver.:)

Do you know what did I do wrong?

I am attaching the settings.rar to see for yourself. One thing that has come up my mind is that problems could have arisen due to the fact that I didn't use the FF 3.6 beta 1 from the link inside the addon maker, but FF 3.6 bet 1 build 3 from Mozilla's ftp. It is very unlikely as I did that before and never had issues.

I am eagerly waiting for your reply

Thank you

Kukubau

Share this post


Link to post
Share on other sites

@Jonnyboy

Hi

I am using your addon since ever and I find it very useful. But using the las two versions I stumbled upon a few problems.

First, a question or two.

What is with this function "Addon Installation Paths" "Click to enter the Addon's Destination folder of your choice, or you can create a new folder.". I don't want to enter a new folder for the addons, I want to use the default path. What is the default path? c:\Program Files\Mozilla Firefox or the profile path C:\Documents and Settings\Andrei\Application Data\Mozilla\Firefox\Profiles\random_name.default By default, in your tool is entered C:\Program Files\Firefox. If that is set,will FF install there instead of c:\Program Files\Mozilla Firefox\ ?!?!

I just reinstalled XP today and ran FF silent built with your addon maker and it failed to install fully. I had to install the original Firefox Setup 3.6 Beta 1 over the first installation so I could open FF. Bad thing is that all my addons were gone. Good thing is that all the bookmarks were there. That was a life saver.:)

Do you know what did I do wrong?

I am attaching the settings.rar to see for yourself. One thing that has come up my mind is that problems could have arisen due to the fact that I didn't use the FF 3.6 beta 1 from the link inside the addon maker, but FF 3.6 bet 1 build 3 from Mozilla's ftp. It is very unlikely as I did that before and never had issues.

I am eagerly waiting for your reply

Thank you

Kukubau

First, thanks.

Firefox Addon Maker is an 'addon maker', so the script needs to know the path to where the addon\installer should install to. Firefox does not have 'addons', it has plugins and extensions. So, Addon Installation Path, is not referring to them. As, I wrote this script for me and I install to %programfiles%\Firefox, that is how that field is populated.

The current posteed version has a bug that is evident when installing extensions as 'global' and this can cause some problems.

This has been, for some time, an inf installer. Even the silent installer is just a modified inf installation. With every new beta, i have to make several changes. This could be causing your problem.

Going forward, I have removed the inf installer and the silent installer uses the firefox installer. Mozilla has made changes to their installer making it possible to install it anyway you like, silently.

I should have the next one ready soon.

Edited by Jonnyboy

Share this post


Link to post
Share on other sites

First, thanks.

Firefox Addon Maker is an 'addon maker', so the script needs to know the path to where the addon\installer should install to. Firefox does not have 'addons', it has plugins and extensions. So, Addon Installation Path, is not referring to them. As, I wrote this script for me and I install to %programfiles%\Firefox, that is how that field is populated.

The current posteed version has a bug that is evident when installing extensions as 'global' and this can cause some problems.

This has been, for some time, an inf installer. Even the silent installer is just a modified inf installation. With every new beta, i have to make several changes. This could be causing your problem.

Going forward, I have removed the inf installer and the silent installer uses the firefox installer. Mozilla has made changes to their installer making it possible to install it anyway you like, silently.

I should have the next one ready soon.

I never select "install the extensions globally", so it has to be something else that's breaking the installation.

Thank you. Waiting for your last version.

Share this post


Link to post
Share on other sites

@kukubau I need the logfile that is generated to even attempt to locate a problem. Please send it to me and I'll see what I can find.

I deleted it. Never mind. Thanks.

Share this post


Link to post
Share on other sites

Is the link ever going to get fixed its a great tool and i lost the last version I had in a reformat so I was just wondering when it might be uploaded again :)

Share this post


Link to post
Share on other sites
Guest

Is the link ever going to get fixed its a great tool and i lost the last version I had in a reformat so I was just wondering when it might be uploaded again :)

see this post here

Share this post


Link to post
Share on other sites

@Jonnyboy

I know that your time is scarce, but you mentioned you've been working on an update. Is it still on?

Greets.

Yes. Soon. There has been many changes to Firefox since the last major update and I'm trying to work it all out.

Sorry for the delay.

Share this post


Link to post
Share on other sites

I have just added this project to Sourceforge.net and I will post the current work, as-is, in just a few minutes. Please, post any bugs on sourceforge.

I will update the main page, here, as soon as I can.

Firefox Addon Maker

Thanks

Edited by Jonnyboy

Share this post


Link to post
Share on other sites

Thanks! But I cant get passed the first screen.

Oh and I get this error @ start:

2jajolf.png

"Cant open the following .reg entry to read it."

Tried pushing Yes and No, but then I just get the screen with the moving text, and cant do anything.

Share this post


Link to post
Share on other sites
Guest

Thanks! But I cant get passed the first screen.

Oh and I get this error @ start:

2jajolf.png

"Cant open the following .reg entry to read it."

Tried pushing Yes and No, but then I just get the screen with the moving text, and cant do anything.

well i don't know but it seems an access denied problem

try to run it as an administrator

Share this post


Link to post
Share on other sites

Correct. UAC doesn't like it when the script looks at the registry.

So, run as admin or disable UAC.

As mentioned in my earlier post. This is not completed, but it does work. I posted only for those that 'could not' wait.

Thanks

Edited by Jonnyboy

Share this post


Link to post
Share on other sites

Correct. UAC doesn't like it when the script looks at the registry.

So, run as admin or disable UAC.

As mentioned in my earlier post. This is not completed, but it does work. I posted only for those that 'could not' wait.

Thanks

I know that.

UAC is disabled, and I ran it as Administrator, error pops up

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...