Jump to content
^SoKoOLz^

[Installer] Windows Sidebar 1.7 XP/2003

Recommended Posts

Okay, it's been a while since I update this installer.

sidebarsetup01.png

sidebarsetup02.png

skzxp01.jpg

This installers contain:

- Vista Fonts

- Gadgets (Extras)

- Gadgets Installer

Prerequisite:

- MSXML 6.0 (must have before installing WLAN API)

- MSXML 6.0 SP1 (optional)

- WLAN API (For XP user, 2003 user won't need this)

- ALKY Tools

- VC2005 Runtime (Required before installing VAIO Tools)

- Alky 1.0 for Windows XP

- VAIO Tools for Windows Server 2003

* After you have successfully installed ALKY you will need to restart your system.

Gadget Dependecies:

- .NET Framework 2.0 ( For some components to run properly)

- Internet Explorer 7 For Windows XP

- Internet Explorer 7 For Windows 2003

- Windows Media Player 11 ( For XP )

CHANGELOG:

{20/11/07}

UPDATE: All components to the latest Vista release

FIX: Many bugs

{30/05/07}

ADD: CPU CORE 4 Gadgets

ADD: ALKY SUPPORT

{17/05/07}

ADD: WMP Gadget

FIX: Now able to select/unselect Gadget Installer

FIX: FONT exist popup

{20/04/07}

FIX: FONT variables

FIX: More Compression

ADD: 2003 Compatibility

ADD: Windows Version Check function

ADD: More gadgets

SET: LiveClock, CPUMeter, and HDD Monitor to default sidebar first start setting.

INSTGUI: Wallpapers and checkboxes

ToDo:

{20/05/07}

- More gadget install section

Pre-Installation step (helper)

(For those of you who got confused with those prerequisites)

XP User Steps:

MSXML 6.0>>>WLAN API>>>VC2005 Runtime>>>ALKY Tools for Windows XP>>>Restart

2003 User Steps:

VC2005 Runtime>>>VAIO Tools for Windows Server 2003>>>Restart

*After you have restarted, then you can start using the Windows Sidebar Installer

This installer also comes with /S , Silent Switch command.

skzdl.gif

Windows Sidebar Installer for Windows XP/2003

Credit:

Ricktendo64 ^_^

[AddOn] Windows Vista RTM Sidebar (XP Only)*

Edited by N1K

Share this post


Link to post
Share on other sites

Links dont work. And, what is the difference between urs and Ricks?

Edit: Links working now, sorry for that.

Edited by MrNxDmX

Share this post


Link to post
Share on other sites
Links dont work. And, what is the difference between urs and Ricks?

Edit: Links working now, sorry for that.

Mine is an NSIS Installer, it is much much faster than Ricks method when use it as an Addon. And it also contains the gadget installer already.

Share this post


Link to post
Share on other sites

Hi guys, hi Ricks! ^SoKoOLz^ i noticed that your installer (i've tried only the 2k3 version) installs vista fonts only in "c:\windows\fonts". Obviously this is not a bug and your work is great but maybe people with a different configuration of their hard drives (like "f:\windows" or else) could encounter some problems.

Except this your installer works like a charm! Byezzzz :welcome:

Share this post


Link to post
Share on other sites
Hi guys, hi Ricks! ^SoKoOLz^ i noticed that your installer (i've tried only the 2k3 version) installs vista fonts only in "c:\windows\fonts". Obviously this is not a bug and your work is great but maybe people with a different configuration of their hard drives (like "f:\windows" or else) could encounter some problems.

Except this your installer works like a charm! Byezzzz :welcome:

Yep peraps you r right, I'll look into that and will release the new version soon. THank you very much.

Share this post


Link to post
Share on other sites
Hey nice theme on the screenshot :)

Where did you get it ?

thnks

That's mine own modified theme.

It includes, VistaCG theme + Vista Aurora BG + Aero II Cursor + Vista RTM sound.

Share this post


Link to post
Share on other sites
Mine is an NSIS Installer, it is much much faster than Ricks method when use it as an Addon. And it also contains the gadget installer already.
hi ^SoKoOLz^! aside from being an NSIS what else is different from Rick's? :) thanks!

Share this post


Link to post
Share on other sites

From my point of view:

Rick installer is still using the INF/true Addon method, which I have to say it is slow and there's a chance for user to make a mistake by pressing cancel button. This method is only good for an addon but not for the installer.

My one is using the installer script which is faster and smaller with better compression. It is definitely good for WPI and normal setup.

If u try both installers u will see the differences.

Share this post


Link to post
Share on other sites

i'm using winserver 2003 SP2, how do i install wireless lan APi if the patch itself says doesn't compatible with winserver 2003 SP2 even tough i turned on the compatibility mode to XP, everytime i run it, it will say

"Sorry. This application attempted to delay-load a library or function that does not exist. Instability may occur."

that is a sign that Wireless Lan API hasn't been installed. I can run it swiftly on XP because i can install that API, how do i do that in winserver 2003 SP2?

Share this post


Link to post
Share on other sites

You don't need WLan API if you are gonna use the sidebar on server 2k3, all you need is VAIO2003 and the sidebar (you might need the atl.dll file from a XP machine, just put it in the same folder as sidebar.exe and you will be fine)

Share this post


Link to post
Share on other sites
From my point of view:

Rick installer is still using the INF/true Addon method, which I have to say it is slow and there's a chance for user to make a mistake by pressing cancel button. This method is only good for an addon but not for the installer.

My one is using the installer script which is faster and smaller with better compression. It is definitely good for WPI and normal setup.

If u try both installers u will see the differences.

thanks SoKoOLz! :) leme try this ... would this mean that updates wouldn't be frequent anymore in rick's work?:(

Share this post


Link to post
Share on other sites

hi SoKoOLz!! i tried slipstreaming this via HFSLIP ... & nLite too ... i was right in thinking it would install at T-13 silently but prompts still came up until the part where you click on Finish ... would the package be good for automatic /S install so that OS install would be unattended? also clock only showed black ... notepad didn't launch ... please know that i had VAIO, WPI and .NET2 integrated too ... oh and btw, how do i add gadgets? didn't see gadget installer installed ... in rick's addon, downloading gadgets and double clicking these automatically added gadgets to the sidebar ... your feedback would be greatly appreciated ... thanks!

Edited by kiki burgh

Share this post


Link to post
Share on other sites

Hello, I have just used your installer it all seems to work well but when I restart I get a starnge error;

The procedure entry point Wow64EnableWow64sRedirection......

Please see picture for more details. I will try to uninstall and reinstall

I am running WinXPSP2 32bit.

Thanks

Share this post


Link to post
Share on other sites

Sorry for my late response.

@kiki burgh

I've checked my installer with /S switch and it seems to work just fine, there will only be a little DOS screen that will still shows up and close automatically. If you are using this with WPI then make sure you have the right quotation.

This is from my WPI config file:

prog[pn]=['Windows Vista Sidebar Installer 1.1 *'];

ordr[pn]=[22];

desc[pn]=['Windows Vista Sidebar for Windows XP'];

uid[pn]=['WVS'];

dflt[pn]=['yes'];

cat[pn]=['Microsoft Softwares'];

forc[pn]=['no'];

cmd1[pn]=['"%wpipath%\\Install\\WindowsXPSidebarInstaller-1.1.exe" /S'];

pn++;

Also, if you still see the black clock, please re-run the installer again and see if it is still got the same error or not? I need to know where did it wnet wrong. Thank you

@modarm

Do you still see this error every time you reboot?

And Do you have Windows XP64-bit installed on the same partition?

Edited by ^SoKoOLz^

Share this post


Link to post
Share on other sites

Hi, I have no XP64-bit installed. However I did fix it by uninstalling and reinstalling which fixed it for a short time. I then started getting another error which I fixed by setting the compatability mode of the sidebar.exe to Windows 2000. So I now have the sidebar functioning its brilliant but still some bugs. If I load the outlook gadget it comes up with an error then if I try and open outlook outlook will not open until I exit the outlook gadget. This only started after I told the sidebar.exe to open in compatibility mode so I guess this is the problem.

Please see image for more info.

I also run:

TopDesk

WindowsBlinds5.5 - Vista32px by Jemaho

Visual tooltip

Office 2003

WinXPsp2

This machine was rebuilt two 4 days ago so its very clean.

Thanks for your support

Share this post


Link to post
Share on other sites
Sorry for my late response.

@kiki burgh

I've checked my installer with /S switch and it seems to work just fine, there will only be a little DOS screen that will still shows up and close automatically. If you are using this with WPI then make sure you have the right quotation.

This is from my WPI config file:

prog[pn]=['Windows Vista Sidebar Installer 1.1 *'];

ordr[pn]=[22];

desc[pn]=['Windows Vista Sidebar for Windows XP'];

uid[pn]=['WVS'];

dflt[pn]=['yes'];

cat[pn]=['Microsoft Softwares'];

forc[pn]=['no'];

cmd1[pn]=['"%wpipath%\\Install\\WindowsXPSidebarInstaller-1.1.exe" /S'];

pn++;

Also, if you still see the black clock, please re-run the installer again and see if it is still got the same error or not? I need to know where did it wnet wrong. Thank you

thanks ^SoKoOLz^! :) would this integrate with nLite or HFSLIP as silent installer? thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...