Jump to content

Windows 7 Forum Trash


Recommended Posts

wow that is huge

i'm trying to download most of the addons to test it with the WA Installer

but man :sweatingbullets: that are really a big pack

thx for your work

i will download one or two and test them

that others are up to you :D

great work

Link to comment
Share on other sites


i had the same problem like beatmaster. I tried to integrate the Realtek-driver and Intel-LAN-Driver. It seems that the DriverIntegrator doesn't updates the registry-entry under "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion" DevicePath. I manuelly edited this key after mounting "install.wim" and loading the hive "SOFTWARE" (in Windows\System32\config) with the Reg-Editor to "%SystemDrive%\W7TDrivers;%SystemRoot%\inf". After a new installation the LAN-Driver was installed, but the Realtek-Driver was not. Maybe it was because the Realtek-Driver is not digitally signed. But i choosed this option in DriverIntegrator.

Did you get a little program running after installation of windows?
What do you mean with this? Could you explain how the DriverIntegrator is working?

Anyway i found some other bugs:

  • If i download some tools or addons (i put them to queue), the queue was not empty after downloading. And if i download a addon that was already stored to harddisk, is was overwritten without prompt. I thinks it's better to ask to overwrite existing files.
  • I tried to change the "DevicePath" with RegistryHiveMounter, but the changes i mad were not stored. I had to mount the "install.wim" and load hive with reg-editor (see above).
  • I tried to add the availibly Updates for Win7 x64 with the UpdateIntegrator, but none of these updates were integrated.

I hope you can help me (us).

PS: I'm working with the latest alpha 0.5.0 on Win7 x64.

Link to comment
Share on other sites

Hi again,

i think i've found the problem. After the DriverIntegrator ends, he doesn't unload the Hive (WIM_Software) and because of this, there where no changes made in "Windows\System32\Config\Software" and so he doesn't stored it to "install.wim".

Another Bug: The "WIM Tweaker" doesn't unload the Hives "WIM_Default" and "WIM_Software" too.

Question: Could you make the Tool like nLite or vLite? That means that the user can choose the options to edit the source (Driver,Addons,Tweaks,...) and after all options were done, it creates a new "install.wim". Now it creates after every run a new "install.wim" (3 times for me (addons/driver/tweaks)) and take a lot of time.

PS: Keep up the good work :thumbsup_anim:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...