Joomla 1.7 – Save failed with error: Invalid parent id.

joomla box

When migrating from 1.5 to Joomla 1.7 you might have issues while saving the new article with Invalid parent id error message.

When you try to save the new article you might receive the following message:

Save failed with the following error: Invalid parent id.

No matter for the error message, article will be saved but won’t get the asset_id.

I’m not sure if this is related with something gone wrong with the migration, but here’s how to fix this error:

Login to Joomla Administrator | Select Menus –> Menu Manager | Click on the Check All box and click Rebuild

Now select Content –> Category Manager | Click on the Check All box and click Rebuild

Open Content –> Category Manager and click on the each top category to open it and then just Save it.

After you’re done with the top categories, open sub categories and save them all one by one

Error message should be gone now when saving new articles.

You should also open article/s that were saved with this error message and save it again.

You may also like...

20 Responses

  1. Lisa says:

    THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  2. MrDu says:

    it don’t work
    i use joomla 1.7.1
    please help me

  3. Walid says:

    thanks man

  4. Robert Long says:

    Great it worked! Thanks

  5. mamun says:

    thanks dude… its really works for me… thanks again

  6. kaloud says:

    it work on joomla 2.5.1 beta !
    Many thanks 2u

  7. Paris Kalog says:

    I had this problem and it was solved
    due to instructions.
    Thanks very much
    Paris

  8. Geda says:

    great, thank you.

  9. Chad says:

    Thanks!!!!!! What a pain in the…

  10. SEO Acuity says:

    that was a small lifesaver, many thanks!

  11. Kishore says:

    You made my day, thanks for the quick small fix…
    Worked like a charm..
    Thanks once again.. 🙂

  12. Milos says:

    Thanks man ! This really helps !

  13. Joom D says:

    VERY VERY HELPFUL !!!!!
    Thanks a lot!!!

  14. RMGraf.eu says:

    Great!!!!!!!! 😆

  15. Olav K says:

    Thanks a lot!
    Had this same problem when creating new Categories in Joomla! 2.5.7
    This fixed it!

  16. marsel says:

    thanks for your help god bless you

  17. Anna Radu says:

    You are awesome! Works like a charm

  18. j3n4 says:

    I LOVE YOU! ^__^

    The same procedure work for joomgallery!

  19. Hóddi says:

    thanks it works 100%

  20. c says:

    Seriously. That is never better

Leave a Reply

Your email address will not be published. Required fields are marked *

13 + 1 =

This site uses Akismet to reduce spam. Learn how your comment data is processed.