Jump to content

[Slim] .NET Framework 4.6.1 Full x86/x64 (2-27-2016)


ricktendo
 Share

Recommended Posts

Rick, your dropbox link: (Integrate this (before you slim) to activate/enable LDR/QFE branch:) is a dead end.

Fixed, aparently DropBox does not like "Read Only" attribs

Edit: Just noticed there is a new .net4.5 installer available, did a refresh using the new installer. plz redownload

Note: The .NET Framework 4.5 redistributable was updated on 10/9/2012 to correct an issue related to an improper timestamp on a digital certificate which causes the digital signature on files produced and signed by Microsoft to expire prematurely. We recommend customers that previously installed the .NET 4.5 redistributable package dated 8/16/2012 install this updated .NET 4.5 redistributable package. More information about the issue can be found Microsoft Security Advisory 2749655.

Edit2: All Language Pack links are now live (yes I did use the refreshed LP installers)

Link to comment
Share on other sites

Rick, I want to repack this for a silent install using the alternate method, But i not clear on what you mean by

Integrate this (before you slim) to activate/enable LDR/QFE branch:

http://adf.ly/1713566/kb2519265

Do you mean to integrate to my media, or to integrate it to my repack?

Do I understand this right?

1. unpack your slim insaller in a folder

2. add NDP45-KB2519265 to same folder

3. 7 zip the whole thing

4. drop the archive on your repack script

Link to comment
Share on other sites

Thank you again Rick for an amazing installer.

However, I do have a question: I see that Microsoft is looking at .net 4.5 from two perspectives - the same problem generates two very different hotfixes, one for vista and 7, and one for 8 and 8 RT. So in this case wouldn't it be recommended to make two separate installers, one for pre-windows 8 OSes, and one for 8? For example, what versions of clrjit.dll and peverify.dll does your installer contain?

Link to comment
Share on other sites

@dotfusion My installer already has KB2519265, this is there only for people who want to make (from scratch) a similar installer. I provide the script to slim, KB2519265 to enable LDR hotfix integration, etc, but you dont need to worry about KB2519265

Just extract my installer (or use 7zsplit to get the 7zip,) add a LP (optional,) use the SFX maker and/or No GUI to rebuild the executable by dragging & dropping the 7z onto the cmd (first editing config.txt to enable LangPack if you added one or to enable the reg add lines that will allow you to install during setup)

@RicaNeaga Windows 8 does not need a installer, you just integrate the update with dism

BTW my installer has KB2519265 applied so the LDR branch is always used

Link to comment
Share on other sites

Oh, great, thanks for the clarification. I'm not very into windows 8 right now, but it's nice to know for the future. So this installer is only for windows 7 & vista - maybe it's a good idea to bold that text in the first post, so some users with windows 8 won't use this. :)

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

BTW I removed /ain switch, because I noticed by default the installer runs ngen so I see no need in running it twice

Thanks for the info. I have one question about the 4.5 .NET: with the .NET 4 you provided a way to install Client or Extended, does this not apply to .NET 4.5? Thank you.

Edited by parapher
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...