Jump to content

[Problem] Windows 7 X64 SP1 - Intergrate Updates


Recommended Posts

Sorry if this is not the right thread/forum.


I've been trying to create a succesful image for a few days now... and I haven't ben able to.

I was using an older program last week called RT7, which hasn't been kept up with very well...


Anyways I decided to get WinToolKit a go. I used it to download a fresh SP1 X64 English disc, along with all of the updates I need to make imaging faster.


I've burnt a few discs and used USBs thinking maybe that was the problem but it seems to be something else.


I get an error or message about the end of the windows 7 installtion.


Check Copying Windows Files

Check Expanding Windows Files

Check Installing Features

Check Installing Updates


- Completing installion.....




This is where I get the error, A prompt pops up about WinToolKit looking for installion files?


It usually fails about an hour later.


Is there something I'm doing wrong here? Do i have to have WinToolkit added to the usb for it to complete the installtion?

The Fail message isWindows could not configure one or more system components. To install Windows, restart the computer and then restart the installation.

TL;DR    Having an error at the end of completing installtion - Looking for WinToolkit installtion Files. Read Fail Msg.


Edited by mastercheem
Link to comment
Share on other sites


You should use a virtual machine (VirtualBox is free and very good) to test your integration.


You can attach your wintoolkit's session.ini here so we can see your settings.

Link to comment
Share on other sites


You should use a virtual machine (VirtualBox is free and very good) to test your integration.


You can attach your wintoolkit's session.ini here so we can see your settings.


I have plenty of laptops to test it on. Thanks though.  I will try to get my .ini file up on here.


So it's most likely one of the updates I tried to intergrate?

Link to comment
Share on other sites

Most likely its a update or a file you reshacked

For updates I suggest KUC for telling you what updates can and cannot be integrated

- mount your image with wintk

- run KUC with these parameters


"KUC W7 UpdateChecker.exe" /DVD-Image-dir:<path_to_mount_folder>
This will give you a list of safe updates you can integrate
Link to comment
Share on other sites

I had the same problem while trying to get IE10 slipstreamed. Found out I was actually missing some required updates. I read where some said you needed 4 updates and then I noticed in wintool  I didn't have all the required updates. 5 or so? Sorry I can't help much. I myself just started working with windows 7 updates to my DVD.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By abbodi1406
      The .NET Framework is a popular development platform for building apps for Windows, Windows Store, Windows Phone, Windows Server, and Windows Azure. The .NET Framework platform includes the C# and Visual Basic programming languages, the common language runtime, and an extensive class library. read more.
      Info: The .NET package will be slipstreamed as pre-installed
      OS: Windows 7 SP1
      - The addon will conflict with some Windows Updates (.NET 3.5 Family), so leave the addon's integration to the last.
      - Add main addon first before LangPack addon, to get ASP.NET service localization properly.
      - To function properly, .NET 4.7.x require D3DCompiler_47.dll component, which is found in either the current "Monthly Quality Rollup" or "update KB4019990". It is recommended to integrate it first, or you can install it later.
      .NET 4.8:
      .NET 4.7.2:
      Languages Codes Reference:
    • By mooms
      For international readers, here is an english thread: (you must be logged to MDL to see it).
      Cet Update Pack constitué d'un seul fichier, il permet de mettre à jour une installation "live" ou de faire une intégration dans une image wim de Windows 7 SP1 ou Server 2008 R2 , à la manière de WinToolkit, que ce soit en x86 ou en x64.
      La télémétrie est désactivée , et un patch pour installer les KB sur les CPU récents (Kaby Lake et + et Ryzen) est inclus.
      Exemple, avec cette commande, le pack va intégrer toutes les màj + IE11 localisé (détection de la langue automatique ) dans tous les index de l'image wim, puis optimiser cette dernière:
      UpdatePack7R2.exe /ie11 /Optimize /WimFile=C:\Win7AIO\sources\install.wim /Index=* Avec celle-ci, le pack va installer passivement les màj + IE11 localisé sur le système, puis redémarrer
      UpdatePack7R2.exe /ie11 /silent /reboot Il est possible de renommer le pack pour automatiser certaines actions:
      Un fil en anglais sur MDL qui en parle, avec liens de téléchargement et exemples:
      Page officielle avec liens de téléchargement (en Russe):
      Ce fichier téléchargera automatiquement la version la plus récente: https://update7.simplix.info/UpdatePack7R2.exe
    • By Tanzil Habib
      Hello, sir, today is September 1, 2020, 11:14 a.m. in Bangladesh. So I am trying to download Windows 7 ISO file, but when I click to download, It shows an error page where headline says "This program cannot display the webpage". I have added screenshots.
      My internet connection is fine but it's not working! Please give me a solution for that!
      Screenshot links in my Google drive:
      1. After selection: https://drive.google.com/file/d/1aChxjI8ugKA7XcU5_nxEabdBzRLUO3B0/view?usp=sharing
      2. The downloading page: https://drive.google.com/file/d/1zi4A-v9vBr1r0MT_fG6K4PrzUTyQKbej/view?usp=sharing
      3. The error: https://drive.google.com/file/d/1QMOmQ8A2leol1DeCy9Gvow6OPyeuWR4X/view?usp=sharing

    • By linkservis
      WinToolkit ver.
      Host/PC OS: Windows 10 (64-bit) v1909
      OS that is being modified: Windows 7 (32-bit) Ultimate
      I keep trying to integrate IE11 into this system but no luck, it bugs and shows the error like in attachment.
      I tried doing same on x64 version of W7Ultimate and it goes with no problem, configuration and updates are same (only 64bit version)

    • By Jhonny Silva
      "This file is currently unavailable. Please check again later."
  • Create New...