Jump to content
Legolash2o

WinToolkit Development

Recommended Posts

Thanks so much! I'm a regular user of this excellent tool. It works wonders on my captured installations & in creating time-saving installations outta fresh ISOs. It's great to see development continuing! 

Edited by davew7v
error in viewing the full sentence properly

Share this post


Link to post
Share on other sites

Is a slight problem that the 2.x test version is expired?

1.x seems somewhat broken on windows 8.1 e.g. the runonce installer is stuck so I thought I would try 2.x and it wont run due to the expiry :(

Share this post


Link to post
Share on other sites

It might be a slightly bigger problem that there's nowhere to download any version of v2.x at all... anyone have a copy of "2.0.5860.25216.7z" they can re-up?

Share this post


Link to post
Share on other sites

I received an email with an important issue so test build v1.5.4.5 has been uploaded.

*1.5.4.5^Added upgrade options for Windows 10
*1.5.4.5^Added upgrade options for Windows 8 CoreConnected
*1.5.4.5^Update rollups integrated after IE
*1.5.4.5^FIX: Removed *.db, *.chk, and *.log files from Cleanup Manager as they can corrupt sfc.exe
*1.5.4.4^FIX: Extended Windows 10 support

Share this post


Link to post
Share on other sites

Hi Liam,

WTK 1.5.4.5 works fine but (see pictures):

WTK_1.5.4.5_b.JPG

1) Must go under "Prerequisite".

 

WTK_1.5.4.5_a.JPG

2) Must go under "Silent Installers + SFX".

3) It's sure it will be integrated/installed after IE11+cumulative update?

4) Must go to "Prerequisite" (because of Convenience Rollup Pack KB3125574).

BTW, updating cache generates an error (uploaded)

TNX for that, Thiersee

Error_1.5.4_1xD34A6A187F1147895C6EA57455B94A28_Ex06001FC1_frmToolsManager_de-DE_292298.log

Edited by Thiersee

Share this post


Link to post
Share on other sites
27 minutes ago, Legolash2o said:

v1.5.4.6 released hopefully addressing those issues.

On loading updates it seems to do it in the correct way, if the answer for point 3) is positive ;).

I'll do an integration later.

Anyway, thanks a lot!

Thiersee

Share this post


Link to post
Share on other sites

I'm terribly sorry for lowering the general happines/enthusiasm, me included!, but there is an strong issue, if you need the function :(:

absolutely no issues in the normal integration process, but if I want to upgrade a wim-file, for example from HP to Professional, the program gives an error and hangs!

With build 1.5.4.4 all is OK, I tried it two times today.

If I integrate with build 1.5.4.4 and upgrade the wim-file with build 1.5.4.6 absolutely no errors!

Here the pictures with the error (no chance to save the error as text-file, the program hängs):

Liam, is it OK if here stays "Know Issues" and not "RunOnce"?

WTK_1.5.4.6_c.JPG

 

 

 

WTK_1.5.4.6_d.JPG

WTK_1.5.4.6_e.JPG

WTK_1.5.4.6_f.JPG

Edited by Thiersee

Share this post


Link to post
Share on other sites

So you want KB3177467 to be at RunOnce? A box should have appeared asking you if you wanted it to be a silent installer. You have to tick the box and click continue if so.

Share this post


Link to post
Share on other sites
10 minutes ago, Legolash2o said:

So you want KB3177467 to be at RunOnce? A box should have appeared asking you if you wanted it to be a silent installer. You have to tick the box and click continue if so.

Of course I did it and the KB has been moved to "Silent Installers + SFX!", but during the integration I saw "Known Issues" in the status-line.

Share this post


Link to post
Share on other sites

Hello, I tried the v1.5.4.6 and have similar problems after some "Known Issues". Screeencap from Virtualbox below.

 

Click OK and it only loops.

 

Will try the new 1.5.4.7 soon.

 

Sorry - same error as below

 

 

Error.jpg

Edited by sweden8

Share this post


Link to post
Share on other sites

Hi Legolas2o,

Wintoolkit 1.5.3.13 not have this problem.

There is a problem in all versions of the following after the 1.5.3.13 version, latest test version 1.5.4.7 too.

OS : Win7 x64 - Working image x86 pro sp1

wtk_error.PNG

Edited by X-Force

Share this post


Link to post
Share on other sites

Any chance for more simple explanation of the changelog?

"*1.5.4.8^All update rollups now go in 2nd phase"

A Very Merry Christmas and so on...

 

Never mind. I agree with Thiersee above.

 

Edited by sweden8

Share this post


Link to post
Share on other sites

There are too many issues in one thread to make sense of it all.

 

xForce: on the 16th October post it seems like you was trying to integrate 32bit updates into an x64 OS.

Thiersee: When you upgraded the image, did you save and unmount first or did you keep it mounted and then upgraded? 'Known Issues' updates usually prevent all other updates after it from being integrated properly. Seems to be common with stack updates. I think from memory you should integrate those first > save & unmount > all other updates, tweaks, etc..

Sweden: I got an email that KB3197868 and other rollups did not get integrated after IE. All update rollups should now go into the 2nd phase (After IE). I'm required to check my emails ALL the time so that's how I found out about that issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...