Jump to content

[Solved + Merged] Silent Installer Issues


ottuh
 Share

Recommended Posts

Fixed all the issues with MSI and MSU files.

EDIT 1:Also if the user (you) don't specify a switch/syntax for msi files the RunOnce will automatically add '/passive /norestart'

EDIT 2: If there is a /forcerestart or /norestart in the specified switch it will change them to '/norestart' and if restart option is not specified then it will auto add /norestart :)

Edited by Legolash2o
Link to comment
Share on other sites

I'm sorry... I deleted the VM, the ISO and the image because I think I made a mistake. I am trying to meet a deadline on a project today but I will do another test as soon as I can

In the meantime can you please post the 'WinToolkit' registry mentioned above please? (HKLM\\WIM_Software\\WinToolkit)

Thanks.

Link to comment
Share on other sites

It´s bad, but theres a bug processing silent installers. With v14017 there was no problem with 2 *.exe, which are silent. With v14020 these 2 *.exe are not installed.

Link to comment
Share on other sites

Thanks for your answer.

First i use a selfcreated sfx installer for directx (directx.exe /silent). The other is a visual C++ Aio, builded by Dimpel @ Winlite Board, also silent. As I discribed, with 14017 no problem.

The 2 *.exe are not listed in Winkit_RunonceLog. Only Kb23..... is shown as installed.

Edited by wela
Link to comment
Share on other sites

Strange, worked great for me both online and VM, did anyone notice what version the RunOnce was, should have been v4.6?

With v14020 Winkit runonce.exe is 4.6.0.0, with v14017 Winkit runonce.exe is 4.5.0.0.

Link to comment
Share on other sites

From what I remember version 18 had different issues (like .msu not installing), so make all the changes with build 20, except silent installers & not-integrable-to-an offline image-.msus with build 10 from here.

But I'm hoping since Lego is back to solve this frustrating bug once and for all. :)

Link to comment
Share on other sites

I was reffering to .msu updates NOT through DISM (works very well since the beginning of time), but as silent installers. The safe bet is still version 10, I'm pretty sure in v18 .msu will not be installed when run at first logon.

Link to comment
Share on other sites

I was reffering to .msu updates NOT through DISM (works very well since the beginning of time), but as silent installers. The safe bet is still version 10, I'm pretty sure in v18 .msu will not be installed when run at first logon.

OK ;) ; I don't have .msu as silent installers.

Link to comment
Share on other sites

NO that's not correct... Almost nothing installed from the list below:

KB974150-x64::;NO;792.74 KB;E:\!Slipstream\_7Tools\_Step-2\00_NtBackup\KB974150-x64.msu;Always Installed

KB974674-x64::;NO;668.16 KB;E:\!Slipstream\_7Tools\_Step-2\00_NtBackup\KB974674-x64.msu;Always Installed

552x64::N/A (Not Needed);NO;9.23 MB;E:\!Slipstream\_7Tools\_Step-2\01-02-Offline\01-KB2533552\552x64.msu;Always Installed

229x64::N/A (Not Needed);NO;193.42 KB;E:\!Slipstream\_7Tools\_Step-2\01-02-Offline\02-KB2603229\229x64.msu;Always Installed

help::N/A (Not Needed);NO;701.34 KB;E:\!Slipstream\_7Tools\_Step-2\03-KB917607\help.msu;Always Installed

fmapi::N/A (Not Needed);NO;237.99 KB;E:\!Slipstream\_7Tools\_Step-2\04-KB943790\fmapi.msu;Always Installed

agent::N/A (Not Needed);NO;2.65 MB;E:\!Slipstream\_7Tools\_Step-2\05-KB969168\agent.msu;Always Installed

activation::N/A (Not Needed);NO;1.35 MB;E:\!Slipstream\_7Tools\_Step-2\06-KB971033\activation.msu;Always Installed

identity::;NO;1.47 MB;E:\!Slipstream\_7Tools\_Step-2\07-KB974405\identity.msu;Always Installed

identityHF2::;NO;2.75 MB;E:\!Slipstream\_7Tools\_Step-2\07-KB974405\identityHF2.msu;Always Installed

Fixit50531::/quiet /passive /norestart;NO;646.50 KB;E:\!Slipstream\_7Tools\_Step-2\08-FixIt50531\Fixit50531.msi;Always Installed

Fixit50688::/quiet /passive /norestart;NO;655.50 KB;E:\!Slipstream\_7Tools\_Step-2\09-Fixit50688\Fixit50688.msi;Always Installed

dotNet::/aic;NO;46.98 MB;E:\!Slipstream\_7Tools\_Step-2\10-DotNet\dotNet.exe;Always Installed

vcredist::;NO;10.77 MB;E:\!Slipstream\_7Tools\_Step-2\11-VisualC\vcredist.exe;Always Installed

fsharp_redist::;NO;857.08 KB;E:\!Slipstream\_7Tools\_Step-2\11-VisualC\fsharp_redist.exe;Always Installed

Kels_Runtimes::;NO;6.17 MB;E:\!Slipstream\_7Tools\_Step-2\12-KelsRuntime\Kels_Runtimes.exe;Always Installed

Silverlight_x64::/q;NO;12.48 MB;E:\!Slipstream\_7Tools\_Step-2\13-Silverlight\Silverlight_x64.exe;Always Installed

javax86::;NO;20.17 MB;E:\!Slipstream\_7Tools\_Step-2\14-Java\javax86.exe;Always Installed

javax64::;NO;20.94 MB;E:\!Slipstream\_7Tools\_Step-2\14-Java\javax64.exe;Always Installed

FS_AiO_x64_full::;NO;25.87 MB;E:\!Slipstream\_7Tools\_Step-2\15-16-Flash-Shockwave-AIO\FS_AiO_x64_full.exe;Always Installed

DirectX::;NO;95.69 MB;E:\!Slipstream\_7Tools\_Step-2\17-DirectX\DirectX.exe;Always Installed

AdbeRdr_silent::;NO;52.05 MB;E:\!Slipstream\_7Tools\_Step-2\18-Acrobat\AdbeRdr_silent.exe;Always Installed

MSCodecPackx64::/qb /norestart;NO;9.15 MB;E:\!Slipstream\_7Tools\_Step-2\19-MS-CodecPack\MSCodecPackx64.msi;Always Installed

kb890830-x64::/Q;NO;16.00 MB;E:\!Slipstream\_7Tools\_Step-2\30-KB890830\kb890830-x64.exe;Always Installed

mbam-setup::/VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-;NO;9.60 MB;E:\!Slipstream\_7Tools\_Step-2\31-MBAM\mbam-setup.exe;Always Installed

mseinstallx64::/s /runwgacheck /o;NO;12.04 MB;E:\!Slipstream\_7Tools\_Step-2\32-MSE\mseinstallx64.exe;Always Installed

mpam-fex64::/q;NO;61.95 MB;E:\!Slipstream\_7Tools\_Step-2\32-MSE\mpam-fex64.exe;Always Installed

nis_full::/q;NO;848.19 KB;E:\!Slipstream\_7Tools\_Step-2\32-MSE\nis_full.exe;Always Installed

KommClean::;NO;167.50 KB;E:\!Slipstream\_7Tools\_Step-2\40-Komm\KommClean.EXE;Always Installed

KommCleanLDR::;NO;167.00 KB;E:\!Slipstream\_7Tools\_Step-2\40-Komm\KommCleanLDR.EXE;Always Installed

KommAddLDR::;NO;167.50 KB;E:\!Slipstream\_7Tools\_Step-2\40-Komm\KommAddLDR.EXE;Always Installed

So let me get this correct in v20 every works apart from EXEs? MSU's and MSI work fine?

I can easily this in one go however, it would start doing the 'Security Warning - Open File' box on every exe lol

Link to comment
Share on other sites

I confirm what compstuff says!

Only the first programm will be installed (and I don't see the version-nr. of installers).


#Silent Installs
FlashPlayerAIO_x64_11.2.202.235::;NO;16.74 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\FlashPlayerAIO_x64_11.2.202.235.exe;Always Installed
FlashPlayerAIO_x86_11.2.202.235::;NO;7.57 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\FlashPlayerAIO_x86_11.2.202.235.exe;Always Installed
ShockwavePlayer_11.6.5.635::;NO;9.29 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\ShockwavePlayer_11.6.5.635.exe;Always Installed
Java7_x64_7.0.40::;NO;18.60 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Java7_x64_7.0.40.exe;Always Installed
Java7_x86_7.0.40::;NO;17.16 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Java7_x86_7.0.40.exe;Always Installed
VisualC++AIO_x64::;NO;17.47 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\VisualC++AIO_x64.exe;Always Installed
Net4FullSlim_x64::;NO;51.88 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Net4FullSlim_x64.exe;Always Installed
AdobeReaderX_10.1.2::;NO;52.26 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\AdobeReaderX_10.1.2.exe;Always Installed
AIDA64_2.50.2000::;NO;13.67 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\AIDA64_2.50.2000.exe;Always Installed
AS-SSD_1.6.4237.30508::;NO;500.65 KB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\AS-SSD_1.6.4237.30508.exe;Always Installed
CDBurnerXP_x64_4.4.1.3099::;NO;5.12 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\CDBurnerXP_x64_4.4.1.3099.exe;Always Installed
ClassicShell_3.5.0::;NO;5.81 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\ClassicShell_3.5.0.exe;Always Installed
CPU-Z-x64_1.60::;NO;1.13 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\CPU-Z-x64_1.60.exe;Always Installed
EditPadLite_7.1.1::;NO;6.19 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\EditPadLite_7.1.1.exe;Always Installed
FileZilla_3.5.3::;NO;4.46 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\FileZilla_3.5.3.exe;Always Installed
FSImageViewer_4.6::;NO;5.30 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\FSImageViewer_4.6.exe;Always Installed
GoogleEarth_6.1.0.5001::;NO;16.48 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\GoogleEarth_6.1.0.5001.exe;Always Installed
Hardcopy::;NO;5.99 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\Hardcopy.exe;Always Installed
IcoFX::;NO;1.54 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\IcoFX.exe;Always Installed
ImgBurn_2.5.7.0::;NO;5.95 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\ImgBurn_2.5.7.0.exe;Always Installed
IrfanView_4.33::;NO;10.18 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\IrfanView_4.33.exe;Always Installed
LogitechWebcamSoftware_HD_2.31.1044.0c::;NO;140.58 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\LogitechWebcamSoftware_HD_2.31.1044.0c.exe;Always Installed
MozillaFirefox_12.0::;NO;16.08 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\MozillaFirefox_12.0.exe;Always Installed
MozillaThunderbird_12.0.1::;NO;17.38 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\MozillaThunderbird_12.0.1.exe;Always Installed
Mp3_Ext::;NO;1.04 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\Mp3_Ext.exe;Always Installed
MSE_x64_4.0.1526.0::;NO;73.15 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\MSE_x64_4.0.1526.0.exe;Always Installed
Notepad++_6.1.3::;NO;5.68 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Notepad++_6.1.3.exe;Always Installed
PDFCreator_1.3.2::;NO;17.32 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\PDFCreator_1.3.2.exe;Always Installed
PDFXVwer_2.5.2.01_silent::;NO;18.37 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\PDFXVwer_2.5.2.01_silent.exe;Always Installed
RealPlayer_15.0.2.72::;NO;26.42 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\RealPlayer_15.0.2.72.exe;Always Installed
SFXMaker_1.3::;NO;2.62 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\SFXMaker_1.3.exe;Always Installed
Shark007_Codecs_3.6.3-x86::;NO;28.36 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Shark007_Codecs_3.6.3-x86.exe;Always Installed
Shark007_Codecs_3.6.3-x64::;NO;45.56 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Shark007_Codecs_3.6.3-x64.exe;Always Installed
Silverlight_x64_5.1.10411.0::;NO;12.69 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Silverlight_x64_5.1.10411.0.exe;Always Installed
Speccy_1.16.317::;NO;2.48 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\Speccy_1.16.317.exe;Always Installed
SpeedFan_446::;NO;2.13 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\SpeedFan_446.exe;Always Installed
TeamViewer_7.0.12979::;NO;3.51 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\TeamViewer_7.0.12979.exe;Always Installed
USSF_1.5.0.0::;NO;973.11 KB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\USSF_1.5.0.0.exe;Always Installed
VirtualCloneDrive_5.4.5.0::;NO;1.69 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\VirtualCloneDrive_5.4.5.0.exe;Always Installed
VlcMediaPlayer_2.0.1::;NO;21.65 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\VlcMediaPlayer_2.0.1.exe;Always Installed
WinRAR-x64_4.11::;NO;1.75 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\WinRAR-x64_4.11.exe;Always Installed
WinZip-x64_16.0.9715::;NO;26.80 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\WinZip-x64_16.0.9715.exe;Always Installed
7-Zip-9.20-x64::;NO;1.41 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Vandit\7-Zip-9.20-x64.exe;Always Installed
Paint.NET_x64::;NO;3.38 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Unantastbar\Paint.NET_x64.exe;Always Installed
Realtek_HD-Audio::;NO;150.49 MB;E:\ServicePacks-Install\Win 7\Windows 7 Toolkit\Thiersee\Realtek_HD-Audio.exe;Always Installed
KB2533552::N/A (Not Needed);NO;9.23 MB;E:\ServicePacks-Install\Win 7\Dr.Windows Update Pack\win7_updatepack_32_x64\patches\Windows6.1-KB2533552-x64.msu;Always Installed

Version 1.4.0.18 works fine!

Edited by Thiersee
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...