Jump to content

[AIO] Microsoft Visual B/C++/F#/J# Redistributable x86/x64


ricktendo
 Share

Recommended Posts

@cs76 Take a look at this topic. It's a Win Toolkit error after integrating KB2592687 and KB2574819 updates. Move those two updates in the silent installer section, and this error won't happen. And make sure you don't integrate them under Updates in AIO!

@Zeus_ Use this addon from yumeyao & ricktendo for xp - look at the post in the middle with links (aug 2012). vc++ 2012 also is not compatible with xp from my knowledge. :)

Thanks for info. In fact it hadn't gave me error at the begining. I think it began to give error after updated .net framework 4 addon. anyway I get rid of Microsoft Visual F# 2.0, Microsoft Visual J# 2.0 and now I use it with just /ai switch. Now it seems OK. And vc++ 2012 doesn't seems to install on XP, I think it skips on XP. I love this AIO for my WPI. :)

Link to comment
Share on other sites

KB2538242 MST Windows Update fix v1.7:

http://adf.ly/1713566/wufix5mst

KB2538243 MST Windows Update fix v3:

http://adf.ly/1713566/wufix8mst

MsiTran.Exe -a <transform>.MST <installer>.MSI:

http://adf.ly/1713566/msitran

Rick could provide help on these how use these

rick i received this error i think this switchless is not compatible during installing windows

post-35082-0-81252900-1352639840_thumb.j

Link to comment
Share on other sites

Thats because visual j needs .net 2.0 to be installed, this is not a svcpack addon

BTW you only need those if you are creating your own installers. You would apply the mst to the msi package so you are not forced by Microsoft Update to download a older version of the runtimes, this is the command you would use

MsiTran.Exe -a <transform>.MST <installer>.MSI

And yes, you are using the wrong sfx maker

Link to comment
Share on other sites

Thats because visual j needs .net 2.0 to be installed, this is not a svcpack addon

ok rick cut to the bottom if i want to make addon svc pack is it possible through your resource tools

because jaynbe and yume yao aio's are not complete your one has all including vc 2012

more over i have made two different iso one through user hiddens pack and other one using nino fabbios

i like the user hiddens update but does contain

Windows PowerShell 2.0 and WinRM 2.0 for Windows XP and Windows Embedded (KB968930)

WindowsSearch-KB940157-XP-x86-enu

WindowsServer2003.WindowsXP-KB963093-x86-ENU

these are still needed to add for complete updated disk

i used the same sfx maker with correct silent switches

but this update gives error of some dot net version not installed i think 2.0 sp1 using user hidden update and Addon_Microsoft.Net_AIO_ROE_20120612

but using nino fabbio one all in one no updates required but windows intial setup is skipped in nino update no same issue with user hidden one.

your aio of runtime works fine except J# one as the above mentioned error but with user hidden update i received not enough space or storage available error after that other addons install fine.

sorry is there a way to make a all in one complete set of vb vc i mean every single one i think yours has every thing but its an installer not an addon how make one i tried to make one using nlaom21.exe nlite addon maker but its taking to much time and the output hundreds of mbs i tried various different ones but result is same.

used your instruction of silent switch /y in sfx maker 1.3.1 got sucess with nino fabbios update pack but the j# is not installing.

is there an addon or cab maker like just locating actual file with mouse pasting the silent switch and locate the save location like the sfx maker its quite easy.

sorry i dont know how to write scripts for addons and how make cab of your own program could you help.

sorry for this lenghty response.

Link to comment
Share on other sites

O sorry, did not see you wanted it w/ no progress bar

Try

/y /gm2 /qn

Apparently still shows all installer windows and progressbars... :g:

Oh well, will try to repackage it...

Wondering only is there a somekind of reason, why there isnt option included to silently install the whole thing...

EDIT: Nevermind, rebuilt it with additional /aiS switch, to have an option to install it all silently... :)

Edited by Etz
Link to comment
Share on other sites

  • 2 weeks later...

Great package!

Noobie nere ... can your package be integrated with nLite along with other security updates? or with RyanVM as addon? (I'm using OnePiece's XP SP3 x86 update pack with RVMI then nLiteing for config.) If your exe runs from command line, then I just run it anytime after install, the sooner the better?

Noobie here ... dumb question, but just to be sure I have to ask someone ... redist pack SP's versus redist pack Gold's ... if I intall RTEs for C++2008 SP1, then that means I do NOT also need to install RTEs for C++2008 (Gold)? Seems obvious, but MS download explanations are so annoying

... MS quote from between the lines "C++2008 SP1 redist package runs programs created with C++2008SP1" from http://www.microsoft...ls.aspx?id=5582

... "C++2008 (Gold) redist package runs programs created with C++2008 (Gold)" from http://www.microsoft...ails.aspx?id=29

... from your dropbox list of hotfixes, for 2008, I couldn't find KB2607389.

Thanks for a great package ....

Link to comment
Share on other sites

It can but you may want to add it after .net2 installs because of visual F/J

many of the files from KB2643995 are included in the MS12-070 KB2716441 security update for SQL Server 2012.

also, Microsoft support KB article 2607389 no longer exists - they've must have removed the page but the actual 2607389 hotfix is still available from MS.

http://www.msfn.org/board/topic/158460-where-to-get-latest-vc-installation-packages/page__view__findpost__p__1017826

Link to comment
Share on other sites

  • 2 weeks later...

Yes future "security" updates will be installed, but for the most part many vc updates are not usually available on WU

Thanks for responding so quickly =D

This is true. I hardly see available security updates for v++ on windows update... I asked more out of curiosity ^^

Ah.. yesterday, when I was installing Photoshop CS6, some errors occurred in the installation: Visual C ++ 2010 (32 and 64 bit) were not installed. This is normal, right? Once I installed your AiO.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Years pass, you keep working on these and I keep coming back... I started programming as a hobby in .NET even as it came out ten years ago and I indeed stumbled upon a J# redist once. I had thought J# only depended on the .NET framework until then.

Now again I'm surprised to see F# in the same situation. However, I've used hundreds and tested thousands of software and I've never encountered one depending on any of these. I can appreciate they're included for the sake of completeness, but people should know they will most like never need J# for example. I on the other hand prefer completeness when integrating/remastering.

Too bad about the errors when other software is trying to install VC++ runtimes. I hope they don't get in the way of successfully finishing installation. I've never had problems although the original redistributables do leave behind files in the root and I delete them manually when I finally notice (although that may not have anything to do with your addon).

 

Thank you for keeping this up to date all the time.

 

Also, maybe you should mention in the post that these sharp runtimes depend on .NET 2/3 or installation will result in an error.

Edited by brunetu
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...